Tri Tiling

Description  
In how many ways can you tile a 3xn rectangle with 2x1 dominoes? 

Here is a sample tiling of a 3x12 rectangle.


Input 
Input consists of several test cases followed by a line containing -1. Each test case is a line containing an integer 0 <= n <= 30.

Output 
For each test case, output one integer number giving the number of possible tilings.

Sample Input 


12 
-1

Sample Output 

153 
2131 

Source 
Waterloo local 2005.09.24

source code

#include<stdio.h>     
long long a[31];    
int main()    
{    
    long long n;  
    int i;    
    a[0]=1;  
    a[2]=3;    
    for(i=4;i<=30;i+=2)    
        a[i]=4*a[i-2]-a[i-4];    
    while(scanf("%lld",&n))    
    {    
        if(n==-1) break;    
        printf("%lld\n",a[n]);    
    }    
}  


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值