poj 3164-最小树形图

参考博文:
F - Command Network
Time Limit:1000MS     Memory Limit:131072KB     64bit IO Format:%I64d & %I64u

Description

After a long lasting war on words, a war on arms finally breaks out between littleken’s and KnuthOcean’s kingdoms. A sudden and violent assault by KnuthOcean’s force has rendered a total failure of littleken’s command network. A provisional network must be built immediately. littleken orders snoopy to take charge of the project.

With the situation studied to every detail, snoopy believes that the most urgent point is to enable littenken’s commands to reach every disconnected node in the destroyed network and decides on a plan to build a unidirectional communication network. The nodes are distributed on a plane. If littleken’s commands are to be able to be delivered directly from a node A to another node B, a wire will have to be built along the straight line segment connecting the two nodes. Since it’s in wartime, not between all pairs of nodes can wires be built. snoopy wants the plan to require the shortest total length of wires so that the construction can be done very soon.

Input

The input contains several test cases. Each test case starts with a line containing two integer N (N ≤ 100), the number of nodes in the destroyed network, and M (M ≤ 104), the number of pairs of nodes between which a wire can be built. The next N lines each contain an ordered pair xi and yi, giving the Cartesian coordinates of the nodes. Then follow M lines each containing two integers i and j between 1 and N(inclusive) meaning a wire can be built between node i and node j for unidirectional command delivery from the former to the latter. littleken’s headquarter is always located at node 1. Process to end of file.

Output

For each test case, output exactly one line containing the shortest total length of wires to two digits past the decimal point. In the cases that such a network does not exist, just output ‘poor snoopy’.

Sample Input

4 6
0 6
4 6
0 0
7 20
1 2
1 3
2 3
3 4
3 1
3 2
4 3
0 0
1 0
0 1
1 2
1 3
4 1
2 3

Sample Output

31.19
poor snoopy
 
   
代码:
#include <cstdio>
#inclue <cmath>
#include <iostream>

using namespace std;

typedef double type;
struct Point {
	double x, y;
}p[MAXN];
struct node {
	int u, v;
	type w;
}edge[MAXN * MAXN];
int pre[MAXN], id[MAXN], vis[MAXN], n, m;
type in[MAXN];
double dis(Point a, Point b) {
	return sqrt((a.x - b.x) * (a.x - b.x) + (a.y - b.y) * (a.y - b.y));
}
type Directed_MST(int root, int V, int E) {
	type ret = 0;
	while(true) {
		for(int i = 0; i < V; i++) in[i] = INF;
		for(int i = 0; i < E; i++) {
			int u = edge[i].u;
			int v = edge[i].v;
			if(edge[i].w < in[v] && u != v) {pre[v] = u; in[v] = edge[i].w;}
		}
		for(int i = 0; i < V; i++) {
			if(i == root) continue;
			if(in[i] == INF) return -1;
		}
		int cnt = 0;
		memset(id, -1, sizeof(id));
		memset(vis, -1, sizeof(vis));
		in[root] = 0;
		for(int i = 0; i < V; i++)  {
			ret += in[i];
			int v = i;
			while(vis[v] != i && id[v] == -1 && v != root) {
				vis[v] = i;
				v = pre[v];
			}
			if(v != root && id[v] == -1) {
				for(int u = pre[v]; u != v; u = pre[u]) id[u] = cnt;
				id[v] = cnt++;
			}
		}
		if(cnt == 0) break; 
		for(int i = 0; i < V; i++)
			if(id[i] == -1) id[i] = cnt++;
		for(int i = 0; i < E; i++) {
			int u = edge[i].u;
			int v = edge[i].v;
			edge[i].u = id[u];
			edge[i].v = id[v];
			if(id[u] != id[v]) edge[i].w -= in[v];
		}
		V = cnt;
		root = id[root];
	}
	return ret;
}
int main() {
	while(scanf("%d%d", &n, &m) != EOF) {
		for(int i = 0; i < n; i++) scanf("%lf%lf", &p[i].x, &p[i].y);
		for(int i = 0; i < m; i++) {
			scanf("%d%d", &edge[i].u, &edge[i].v);
			edge[i].u--;
			edge[i].v--;
			if(edge[i].u != edge[i].v) 
				edge[i].w = dis(p[edge[i].u], p[edge[i].v]);
			else edge[i].w = INF; 
		}
		type ans = Directed_MST(0, n, m);
		if(ans == -1) printf("poor snoopy\n");
		else printf("%.2f\n", ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值