poj 1699(2013@USC D题)

Best Sequence
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 4119 Accepted: 1634

Description

The twenty-first century is a biology-technology developing century. One of the most attractive and challenging tasks is on the gene project, especially on gene sorting program. Recently we know that a gene is made of DNA. The nucleotide bases from which DNA is built are A(adenine), C(cytosine), G(guanine), and T(thymine). Given several segments of a gene, you are asked to make a shortest sequence from them. The sequence should use all the segments, and you cannot flip any of the segments.

For example, given 'TCGG', 'GCAG', 'CCGC', 'GATC' and 'ATCG', you can slide the segments in the following way and get a sequence of length 11. It is the shortest sequence (but may be not the only one).

Input

The first line is an integer T (1 <= T <= 20), which shows the number of the cases. Then T test cases follow. The first line of every test case contains an integer N (1 <= N <= 10), which represents the number of segments. The following N lines express N segments, respectively. Assuming that the length of any segment is between 1 and 20.

Output

For each test case, print a line containing the length of the shortest sequence that can be made from these segments.

Sample Input

1
5
TCGG
GCAG
CCGC
GATC
ATCG

Sample Output

11


DFS暴搜

网上的很多解题报告都说明这道题是按位DP。。

不过因为最开始做这道题的时候,觉得搜索直接可以过,按照这样的想法码下来就过了~


重点在于在搜索之前,先预处理一下:求出任意两组字符串头尾匹配以及尾头匹配的最大长度。

这样处理之后,就可以直接暴搜了。。。

求字符串按照怎样的序列排序后,可以使每个重合长度达到最大。

这也就是枚举每一中不同序列的重合长度,求出重合最多的。


代码:

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<fstream>
using namespace std;
struct node{
       char cha[25];
       int len;
};
node a[20];
int minn;
int n;
int flag[100];
int dp[25][25];
int compar(int a1,int a2){
    int g,k;
    for(int j=0;j<a[a1].len;j++){
            for(k=j,g=0;k<a[a1].len&&g<a[a2].len;k++,g++){
                    if(a[a1].cha[k]!=a[a2].cha[g]){
                         break;
                         }
                         }
            if(k==a[a1].len){
                 return g;
                 }
                 }
    return 0;
}
int DFS(int start,int num,int minlen){
    if(num==n){
        if(minn>minlen){
             minn=minlen;
        //     cout<<minlen<<endl;
             }
        return 0;
        }
    for(int j=0;j<n;j++){
            if(flag[j]==0){
               flag[j]=1;
               int templen=0;
               if(num==0)
                    templen=a[j].len;
               else{
                    templen=minlen+a[j].len-dp[start][j];
            //        cout<<num<<' '<<templen<<endl;
                  //  cout<<templen<<endl;
                    }
               DFS(j,num+1,templen);
               flag[j]=0;
               }
               }
    return 0;
}
int main(){
 //   freopen("poj 1699.in","r",stdin);
 //   freopen("poj 1699.out","w",stdout);
    int m;
    cin>>m;
    while(m--){
  //     int n;
       cin>>n;
       minn=100000;
       memset(a,0,sizeof(a));
       memset(flag,0,sizeof(flag));
       for(int i=0;i<n;i++){
               scanf("%s",a[i].cha);
               int lenth=strlen(a[i].cha);
               a[i].len=lenth;
               }
       for(int i=0;i<n;i++){
               for(int h=0;h<n;h++){
                      dp[i][h]=compar(i,h);
                //      cout<<i<<" "<<h<<" "<<dp[i][h]<<endl;
                      }
                      }
       //flag[0]=1; 
       DFS(0,0,0);
       cout<<minn<<endl;
       }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值