HDOJ 1001 Sum Problem

杭电 1001

Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
Input
The input will consist of a series of integers n, one integer per line.
Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
Sample Input

100
Sample Output
1   

 

 5050

 

//这题用公式做如果不作处理会数据溢出
 题目中有这样一句话
 You may assume the result will be in the range of 32-bit signed integer
 虽然说结果在32位整型以内,但是公式是n*(n+1)/2
 电脑在计算n*(n+1)的时候其实已经溢出了//

常规(不会溢出)

#include<stdio.h>
int main()
{
    int n,i,sum;
    while(scanf("%d",&n)!=EOF)
    {
      sum=0;
      for(i=1;i<=n;i++)
      {
        sum+=i;
      }
      printf("%d\n\n",sum);
    }
    return 0;
}

类型名n

#include <stdio.h>
int main()
{
    __int64 n;
   
    while (scanf("%d", &n) != EOF)
    {
        printf("%I64d\n\n",  (1 + n) * n / 2);
    }
    return 0;
}

类型名sum

#include <stdio.h>
int main()
{
    int n;
    __int64 sum = 0;
   
    while (scanf("%d", &n) != EOF)
    {
        sum = (n % 2) == 0 ? ((1 + n) * (n / 2)) : ((1 + n)/2 * n);
        printf("%I64d\n", sum);
        printf("\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值