又见GCD
Problem Description
有三个正整数a,b,c(0<a,b,c<10^6),其中c不等于b。若a和c的最大公约数为b,现已知a和b,求满足条件的最小的c。
Input
第一行输入一个n,表示有n组测试数据,接下来的n行,每行输入两个正整数a,b。
Output
输出对应的c,每组测试数据占一行。
Sample Input
2 6 2 12 4
Sample Output
4 8
#include<stdio.h>
int gcd(int m,int n)
{
return(n==0?m:gcd(n,m%n));
}
int main()
{
int T;
int a,b;
scanf("%d",&T);
while(T--)
{
scanf("%d%d",&a,&b);
for(int i=2;i<=a*b;i++)
{
if(gcd(a,i)==b&&i!=b) { printf("%d\n",i); break;}
else continue;
}
}
return 0;
}