HDU_3351 Seinfeld

Seinfeld

2014-8-1
/*
贪心方法:从左向右遍历,遇到左括号lef++,遇到右括号,若lef>0,lef--,
否则右括号变为左括号,ans++,lef++,最后再加上多下来的左括号,即lef/2。 比如前面都排好了,后
四个是左括号,那么就得进行两次变换
*/
 
Problem Description
I’m out of stories. For years I’ve been writing stories, some rather silly, just to make simple problems look difficult and complex problems look easy. But, alas, not for this one.
You’re given a non empty string made in its entirety from opening and closing braces. Your task is to find the minimum number of “operations” needed to make the string stable. The definition for being stable is as follows:
1. An empty string is stable.
2. If S is stable, then {S} is also stable.
3. If S and T are both stable, then ST (the concatenation of the two) is also stable.
All of these strings are stable: {}, {}{}, and {{}{}}; But none of these: }{, {{}{, nor {}{.
The only operation allowed on the string is to replace an opening brace with a closing brace, or visa-versa.
 


 

Input
Your program will be tested on one or more data sets. Each data set is described on a single line. The line is a non-empty string of opening and closing braces and nothing else. No string has more than 2000 braces. All sequences are of even length.
The last line of the input is made of one or more ’-’ (minus signs.)

 


 

Output
For each test case, print the following line:
k. N
Where k is the test case number (starting at one,) and N is the minimum number of operations needed to convert the given string into a balanced one.
Note: There is a blank space before N.
 


 

Sample Input
  
  
}{ {}{}{} {{{} ---
 


 

Sample Output
  
  
1. 2 2. 0 3. 1

 

#include<cstdio>
#include<cstring>
const int maxn=2005;
char str[maxn];

int main()
{
    int count=1;
    while(scanf("%s", str)&&str[0]!='-')
    {
        int i, ans=0, lef=0;
        for(i=0; str[i]!='\0'; i++)
        {
            if(str[i]=='{')
                lef++;
            else if(str[i]=='}'&&lef>0)
                lef--;
            else  if(str[i]=='}' && lef<=0)
            {
                ans++;lef++;
            }
        }
        printf("%d. %d\n", count++, ans+lef/2);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值