BestCoder Round #49 Untitled / hdu5339 (搜索)

Untitled

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 840    Accepted Submission(s): 472


Problem Description
There is an integer  a  and  n  integers  b1,,bn . After selecting some numbers from  b1,,bn  in any order, say  c1,,cr , we want to make sure that  a mod c1 mod c2 mod mod cr=0  (i.e.,  a  will become the remainder divided by  ci  each time, and at the end, we want  a  to become  0 ). Please determine the minimum value of  r . If the goal cannot be achieved, print  1  instead.
 

Input
The first line contains one integer  T5 , which represents the number of testcases. 

For each testcase, there are two lines:

1. The first line contains two integers  n  and  a  ( 1n20,1a106 ).

2. The second line contains  n  integers  b1,,bn  ( 1in,1bi106 ).
 

Output
Print  T  answers in  T  lines.
 

Sample Input
  
  
2 2 9 2 7 2 9 6 7
 

Sample Output
  
  
2 -1
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5342  5341  5340  5339  5338 
 
解析:直接暴力搜索就好了。
           
           第一次提交时,惊喜的发现居然排在第二位,exe.memory为1416kb,然后不断测试,显示删掉多余变量,然后又直接把对输入数据的排序给去掉,就排第一了,好开森。。。。。
代码:
<span style="font-size:14px;">#include<cstdio>
#include<algorithm>
using namespace std;

int a[30],n,m,ans;

void dfs(int step,int x)
{
  if(step>=ans)return;
  for(int i=1;i<=n;i++)
   {
     if(x%a[i]==0){ans=step;return;}
     if(x>a[i])dfs(step+1,x%a[i]);
   }
}

int main()
{
  int i,j,t;
  while(scanf("%d",&t)==1)
    for(i=1;i<=t;i++)
      {
        scanf("%d%d",&n,&m);
        for(j=1;j<=n;j++)scanf("%d",&a[j]);
        ans=30,dfs(1,m);
        if(ans==30)printf("%d\n",-1);
        else printf("%d\n",ans);
      }
  return 0;
}</span>


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值