BestCoder Round #50 Distribution money 即 hdu5364 (排序)

Distribution money

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 379    Accepted Submission(s): 227


Problem Description
AFA want to distribution her money to somebody.She divide her money into n same parts.One who want to get the money can get more than one part.But if one man's money is more than the sum of all others'.He shoule be punished.Each one who get a part of money would write down his ID on that part.
 

Input
There are multiply cases.
For each case,there is a single integer n(1<=n<=1000) in first line.
In second line,there are n integer a1,a2...an(0<=ai<10000)ai is the the ith man's ID.
 

Output
Output ID of the man who should be punished.
If nobody should be punished,output -1.
 

Sample Input
  
  
3 1 1 2 4 2 1 4 3
 

Sample Output
  
  
1 -1
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5368  5367  5366  5365  5363 
 
解析:题意就是对于长度为n的序列,判断其中是否有一个数字的出现次数超过n/2次。若有,输出这个数字;若无,输出-1。
          直接读入之后排序,然后扫描判断时候存在一段连续的相等数字个数大于n/2。
代码:
#include<cstdio>
#include<algorithm>
#define maxn 1000
using namespace std;

int a[maxn+20];

int main()
{
  int i,j,k,n;
  while(scanf("%d",&n)!=EOF)
    {
      for(i=1;i<=n;i++)scanf("%d",&a[i]);
      sort(a+1,a+n+1);
      k=n/2,j=1;
      for(i=2;i<=n;i++)
        {
          if(a[i]==a[i-1]){j++;continue;}
          if(j>k){i--;break;}
          j=1;
		}
	  if(j>k)printf("%d\n",a[i]);
	  else printf("-1\n");
	}
  return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值