HDU 5364 Distribution money 模拟

Distribution money

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 213    Accepted Submission(s): 121


Problem Description
AFA want to distribution her money to somebody.She divide her money into n same parts.One who want to get the money can get more than one part.But if one man's money is more than the sum of all others'.He shoule be punished.Each one who get a part of money would write down his ID on that part.
 

Input
There are multiply cases.
For each case,there is a single integer n(1<=n<=1000) in first line.
In second line,there are n integer a1,a2...an(0<=ai<10000)ai is the the ith man's ID.
 

Output
Output ID of the man who should be punished.
If nobody should be punished,output -1.
 

Sample Input
  
  
3 1 1 2 4 2 1 4 3
 

Sample Output
  
  
1 -1
 

Source
 
设置一个数组,每一个元素代表一个人,输入数据的时候,出现谁就把它的数值加1,最后枚举每一个元素,看它的数值是否大于其它所有元素数值的总和。

#include <iostream>
#include <memory.h>
using namespace std;

int people[10010];
int punish[10010];
int n,id,num;

int main()
{
    int i;
    int flag;
    while(cin>>n)
    {
        memset(people,0,sizeof(people));
        flag=0;
        num=0;
        for(i=0;i<n;i++)
        {
            cin>>id;
            people[id]++;
        }
        for(i=1;i<10010;i++)
        {
            if(people[i]!=0)
            {
                if(people[i]>(n-people[i]))
                {
                    punish[num++]=i;
                    flag=1;
                }
            }
        }
        if(flag==1)
        {
            for(i=0;i<num-1;i++)
                cout<<punish[i]<<' ';
            cout<<punish[i]<<endl;
        }
        else
            cout<<-1<<endl;
    }
    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值