BestCoder Round #50 Run 即 hdu5365(暴力枚举)

Run

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 850    Accepted Submission(s): 370


Problem Description
AFA is a girl who like runing.Today,he download an app about runing .The app can record the trace of her runing.AFA will start runing in the park.There are many chairs in the park,and AFA will start his runing in a chair and end in this chair.Between two chairs,she running in a line.she want the the trace can be a regular triangle or a square or a regular pentagon or a regular hexagon.
Please tell her how many ways can her find.
Two ways are same if the set of chair that they contains are same.
 

Input
There are multiply case.
In each case,there is a integer n(1 < = n < = 20)in a line.
In next n lines,there are two integers xi,yi(0 < = xi,yi < 9) in each line.
 

Output
Output the number of ways.
 

Sample Input
  
  
4 0 0 0 1 1 0 1 1
 

Sample Output
  
  
1
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5368  5367  5366  5363  5362 
 
解析:官方题解:
/*
地球人都知道整点是不能构成正五边形和正三边形和正六边形的,所以只需暴力枚举四个点判断是否是正四边形即可。假如你不是地球人,那么即使暴力枚举正三边形和稍微不那么暴力地找正五边形和正六边形也是可以通过的(反正找不到)。
*/
(外星人在此参上-_-||)
代码:
#include<cstdio>
using namespace std;

int n,f[30][30];
struct tnode{int x,y;}q[30];

int main()
{ 
  int i,j,k,p,a,b,ans;
  while(scanf("%d",&n)!=EOF)
    {
      for(i=1;i<=n;i++)scanf("%d%d",&q[i].x,&q[i].y);
      for(i=1;i<n;i++)
        for(j=i+1;j<=n;j++)
          {
            a=q[i].x-q[j].x,b=q[i].y-q[j].y;
            f[i][j]=a*a+b*b,f[j][i]=f[i][j];
		  }
	  
	  ans=0;
	  for(i=1;i<n;i++)
	    for(j=i+1;j<n;j++)
	      for(k=j+1;k<n;k++)
	        for(p=k+1;p<=n;p++)
	          {
	            if(f[i][j]==f[i][k] && f[i][j]+f[i][k]==f[j][k] &&
				   f[i][j]==f[j][p] && f[j][p]==f[p][k])
				   {ans++;continue;}
				if(f[i][j]==f[i][p] && f[i][j]+f[i][p]==f[j][p] && 
				   f[i][j]==f[j][k] && f[j][k]==f[k][p])
				   {ans++;continue;}
				if(f[i][k]==f[i][p] && f[i][k]+f[i][p]==f[k][p] &&
				   f[i][k]==f[k][j] && f[k][j]==f[j][p])
				   {ans++;continue;} 
			  }
      printf("%d\n",ans);
	}
  return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值