hdu 5365 Run 枚举


Run

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 839    Accepted Submission(s): 361


Problem Description
AFA is a girl who like runing.Today,he download an app about runing .The app can record the trace of her runing.AFA will start runing in the park.There are many chairs in the park,and AFA will start his runing in a chair and end in this chair.Between two chairs,she running in a line.she want the the trace can be a regular triangle or a square or a regular pentagon or a regular hexagon.
Please tell her how many ways can her find.
Two ways are same if the set of chair that they contains are same.
 

Input
There are multiply case.
In each case,there is a integer n(1 < = n < = 20)in a line.
In next n lines,there are two integers xi,yi(0 < = xi,yi < 9) in each line.
 

Output
Output the number of ways.
 

Sample Input
      
      
4 0 0 0 1 1 0 1 1
 

Sample Output
      
      
1
 

Source
 

只有四边形的才是答案。枚举四个点。有6条边,4边相等,剩下两条边也相等,且长度是sqrt(2)*短边即可


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include<cstdio>
using namespace std;
struct Point{
    int x,y;
    Point(int _x=0,int _y=0):x(_x),y(_y){}
};
Point operator - (Point a,Point b){
    return Point(a.x-b.x,a.y-b.y);
}
int len(Point a){
    return a.x*a.x+a.y*a.y;
}

Point p[21];
vector<Point> po;
int ans;
int n;
vector<int> e;
void dfs(int q,int num){
    if(num == 4){
        e.clear();
        for(int i = 0;i < 4; i++){
            for(int j = i+1;j < 4;j ++){
                e.push_back(len(po[i]-po[j]));
            }
        }
        sort(e.begin(),e.end());
        if(e[0] == e[1] && e[1] == e[2] && e[2] == e[3] && e[4] == 2*e[1] && e[5] == 2*e[1])
            ans += 1;
        return ;
    }
    for(int i = q;i < n; i++){
        po.push_back(p[i]);
        dfs(i+1,num+1);
        po.pop_back();
    }
}
int main(){
    while(scanf("%d",&n)!=EOF){
        for(int i = 0;i < n; i++)
            scanf("%d%d",&p[i].x,&p[i].y);
        ans = 0;
        dfs(0,0);
        int res = 0;
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

GDRetop

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值