BestCoder Round #50 The mook jong 即hdu5366 (动态规划)

The mook jong

 
 Accepts: 221
 
 Submissions: 306
 Time Limit: 2000/1000 MS (Java/Others)
 
 Memory Limit: 65536/65536 K (Java/Others)
Problem Description

ZJiaQ want to become a strong man, so he decided to play the mook jong。ZJiaQ want to put some mook jongs in his backyard. His backyard consist of n bricks that is 1*1,so it is 1*n。ZJiaQ want to put a mook jong in a brick. because of the hands of the mook jong, the distance of two mook jongs should be equal or more than 2 bricks. Now ZJiaQ want to know how many ways can ZJiaQ put mook jongs legally(at least one mook jong).

Input

There ar multiply cases. For each case, there is a single integer n( 1 < = n < = 60)

Output

Print the ways in a single line for each case.

Sample Input
1	
2
3
4
5
6
Sample Output
1
2
3
5
8
12

解析:f[i]表示长度为 i 得方案数,则:

          f[i]=            f[i-1]           +             f[i-3]            +        1

              最后一个不放木桩          最后一个放木桩         只在最后一格放木桩

代码:

#include<cstdio>
long long a[70];

int main()
{
  int i,j,k;
  a[1]=1,a[2]=2,a[3]=3;
  for(i=4;i<=60;i++)a[i]=a[i-1]+a[i-3]+1;
  while(scanf("%d",&k)!=EOF)
    printf("%I64d\n",a[k]);
  return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值