hdu 1160 FatMouse's Speed(DP)

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=1160


FatMouse's Speed

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13974    Accepted Submission(s): 6170
Special Judge


Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
 

Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.
 

Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that

W[m[1]] < W[m[2]] < ... < W[m[n]]

and

S[m[1]] > S[m[2]] > ... > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.
 

Sample Input
  
  
6008 1300 6000 2100 500 2000 1000 4000 1100 3000 6000 2000 8000 1400 6000 1200 2000 1900
 

Sample Output
  
  
4 4 5 9 7

题意:求出最长的序列,该序列满足当质量严格上升的时候,速度值严格下降


解题思路:首先他有2个关键量需要有大小顺序,我们可以取先把数据按质量从小到大排序,质量相同的,速度也按从小到大排序(这样即使质量相同也不会取到)。

我们就可以按照最长上升子序列的思路进行枚举,设数组dp[i]为以第i个数为结尾,满足题意的序列最长的长度。

具体思路可以参照 我的另一篇博客 http://blog.csdn.net/zero_witty/article/details/51510809

至于题目所求的序列,可以通过pre[i]记录i的前驱顶点,每次更新dp[i],就更新前驱数组pre[i];

具体代码如下:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<set>
#include<cmath>
#include<vector>
#include<map>
#include<stack>
using namespace std;
typedef long long ll;
const int maxn   = 1004;
struct  tmp
{
    int w;
    int v;
    int id;
} node[maxn];
int pre[maxn];
bool cmp(const tmp&a,const tmp&b)
{
    if(a.w==b.w)
        return a.v<b.v;
    return a.w<b.w;
}
int dp[maxn];
int main()
{
    int cnt = 0;
    memset(pre,-1,sizeof(pre));
    int maxi = 0;
    while(~scanf("%d%d",&node[cnt].w,&node[cnt].v)&&(node[cnt].id = cnt+1)&&++cnt);
    sort(node,node+cnt,cmp);
//    for(int i = 0 ; i < cnt ; i ++)
//    {
//        cout << node[i].w <<' '<<node[i].v <<endl;
//    }
    for(int i  = 0 ; i < cnt ; i ++)
    {
        dp[i] = 1;
        for(int j = 0 ; j < i ; j ++)
        {
          if(node[j].v>node[i].v&&dp[i]<dp[j] + 1)
          {
              pre[i] = j;
              dp[i] = dp[j] + 1;
          }
        }
        if(dp[maxi]<dp[i])
            maxi = i;
    }
    cout << dp[maxi]<<endl;
    int ret = maxi;
    stack<int>s;
    s.push(node[ret].id);
    while(pre[ret]!=-1)
    {
        s.push(node[pre[ret]].id);
        ret = pre[ret];
    }
    while(!s.empty())
    {
        cout << s.top() <<endl;
        s.pop();
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值