hdu2846 Repository

Repository

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3735    Accepted Submission(s): 1366


Problem Description
When you go shopping, you can search in repository for avalible merchandises by the computers and internet. First you give the search system a name about something, then the system responds with the results. Now you are given a lot merchandise names in repository and some queries, and required to simulate the process.
 

Input
There is only one case. First there is an integer P (1<=P<=10000)representing the number of the merchanidse names in the repository. The next P lines each contain a string (it's length isn't beyond 20,and all the letters are lowercase).Then there is an integer Q(1<=Q<=100000) representing the number of the queries. The next Q lines each contains a string(the same limitation as foregoing descriptions) as the searching condition.
 

Output
For each query, you just output the number of the merchandises, whose names contain the search string as their substrings.
 

Sample Input
  
  
20 ad ae af ag ah ai aj ak al ads add ade adf adg adh adi adj adk adl aes 5 b a d ad s
 

Sample Output
  
  
0 20 11 11 2
 

Source
 

Recommend
gaojie   |   We have carefully selected several similar problems for you:   2852  2847  2845  2850  2851 
 


解析:对于一个长度为len的单词,将其子串[k,len)(0<=k<len)存入字典树,v[i]记录经过 i 节点的次数,对于每个单词,v[i]只记录一次。

          

注意这种数据:

2
sdasda
dadad
1
asdasa


代码:

#include<cstdio>
#include<cstring>
using namespace std;

const int maxn=1e6;
const int max_len=20;
int num,f[maxn][26];
int flag[maxn],v[maxn];
char s[max_len+5];

int main()
{
  //freopen("1.in","r",stdin);
  
  int n,i,j,k,x,len;
  scanf("%d",&n);
  for(x=1;x<=n;x++)
    {
      scanf("%s",s),len=strlen(s);
      for(k=0;k<len;k++)
        for(i=0,j=k;j<len;j++)
          {
            if(f[i][s[j]-'a']==0)f[i][s[j]-'a']=++num;
            i=f[i][s[j]-'a'];
            if(flag[i]!=x)flag[i]=x,v[i]++;
		  }
	}
  scanf("%d",&n);
  while(n--)
    {
      scanf("%s",s),len=strlen(s);
      for(i=f[0][s[0]-'a'],j=1;i&&j<len;i=f[i][s[j++]-'a']);
      printf("%d\n",(j<len)?0:v[i]);
	}
  return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值