杭电1312 Red and Black【递归搜索】

12 篇文章 0 订阅
Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 

Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
  
  
45 59 6 13

 

 

#include<stdio.h>
#include<string.h>

int n,m;
int hash[30][30];
char map[30][30];

void DFS(int x,int y)
{
    if(x>n||y>m||hash[x][y]||map[x][y]=='#')
//    hash[][]==1 如果已经走过就说明已经循环了 
        return;

    hash[x][y]=1;
    
    DFS(x-1,y);
    DFS(x+1,y);
    DFS(x,y-1);
    DFS(x,y+1);
}
int main()
{
    while(scanf("%d%d%*c",&m,&n),n+m)
//注意m,n的顺序,且要加%*c否则出错因为后面接下来的是字符输入,如果不加回车将会以字符读入。
    
    {
        int x,y,i,j;
        memset(hash,0,sizeof(hash));
        for(i=0;i<30;i++)
        {
            for(j=0;j<30;j++)
            {
                map[i][j]='#';
            }

        }//注意初始化,为了边界 
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=m;j++)
            {
                scanf("%c",&map[i][j]);
                if(map[i][j]=='@')
                {
                    x=i;
                    y=j;
                }
            }
            getchar();
            //注意加getchar()否则会将空行当字符输入。
        }
        DFS(x,y);
        int sum=0;
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=m;j++)
            {
                if(hash[i][j])
                {
                    sum++;
                }
            }
        }
        printf("%d\n",sum);
    } 
    return 0;
}


 

#include<stdio.h>
int m,n;
int cnt;
char a[1010][1001];
void dfs(int x,int y)
{
    if(a[x][y]=='#') return ;
    if(x > n || x < 1 || y > m || y < 1 )
        return ;
    cnt++;
    a[x][y]='#';
    dfs(x-1,y);
    dfs(x+1,y);
    dfs(x,y+1);
    dfs(x,y-1);
}
int main()
{
    int i,j;
    int x,y;
    while(scanf("%d%d",&m,&n),m|n)
    {
        cnt=0;
        for(i=1;i<=n;++i)
        {
            getchar();
            for(j=1;j<=m;++j)
            {
                scanf("%c",a[i]+j);
                if(a[i][j]=='@')
                    x=i,y=j;
            }
        }
        dfs(x,y);
        printf("%d\n",cnt);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值