Red and Black
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 10122 Accepted Submission(s): 6313
Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
Sample Output
45 59 6 13
Source
#include<stdio.h>
char s[25][25];
int a[4]={0,0,1,-1};
int b[4]={1,-1,0,0};
int m,n,sum;
void bfs(int x,int y)
{
int k,v,t;
s[x][y]='#';
for(k=0;k<4;k++)
{
v=x+a[k];
t=y+b[k];
if(s[v][t]=='.'&&v>=1&&v<=n&&t>=0&&t<m)
{
bfs(v,t);
sum++;
}
}
}
int main()
{
int i,j;
while(scanf("%d%d",&m,&n)&&(m+n))
{
for(i=1;i<=n;i++)
scanf("%s",s[i]);
for(i=1,sum=1;i<=n;i++)
{
for(j=0;j<m;j++)
{
if(s[i][j]=='@')
bfs(i,j);
}
}
printf("%d\n",sum);
}
return 0;
}