HDU杭电4883 TIANKENG’s restaurant

17 篇文章 0 订阅

Problem Description
TIANKENG manages a restaurant after graduating from ZCMU, and tens of thousands of customers come to have meal because of its delicious dishes. Today n groups of customers come to enjoy their meal, and there are Xi persons in the ith group in sum. Assuming that each customer can own only one chair. Now we know the arriving time STi and departure time EDi of each group. Could you help TIANKENG calculate the minimum chairs he needs to prepare so that every customer can take a seat when arriving the restaurant?
 

Input
The first line contains a positive integer T(T<=100), standing for T test cases in all.

Each cases has a positive integer n(1<=n<=10000), which means n groups of customer. Then following n lines, each line there is a positive integer Xi(1<=Xi<=100), referring to the sum of the number of the ith group people, and the arriving time STi and departure time Edi(the time format is hh:mm, 0<=hh<24, 0<=mm<60), Given that the arriving time must be earlier than the departure time.

Pay attention that when a group of people arrive at the restaurant as soon as a group of people leaves from the restaurant, then the arriving group can be arranged to take their seats if the seats are enough.
 

Output
For each test case, output the minimum number of chair that TIANKENG needs to prepare.
 

Sample Input
  
  
2 2 6 08:00 09:00 5 08:59 09:59 2 6 08:00 09:00 5 09:00 10:00
 

Sample Output
  
  
11 6
 

//我在比赛时写的代码,又错了,思路我觉得没有错,已经有大神找到,就是出现连续相交的区间时,当第一个区间的人就走完了,那个座位还是可以给下下下一个区间的人坐的,所以这种方法不对

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct people
{
    char st[20];//来的时间
    char et[20];//走的时间
    int sum;
}arr[10010];
bool cmp(people a,people b)
{
    return strcmp(a.et,b.et)<0;
}
int main()
{
    int t,n,i;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i=0;i<n;++i)
            scanf("%d %s %s",&arr[i].sum,arr[i].st,arr[i].et);//以前写过一道题,这个时间可以用字符串比较,因为是按照一定格式写的,所以以字符串输入没问题
        sort(arr,arr+n,cmp);
        int cnt=arr[0].sum;
        
        for(i=1;i<n;++i)
        {
            if(strcmp(arr[i-1].et,arr[i].st)>0)//如果有公共部分
            {
                cnt+=arr[i].sum;
            }
            else
            {
                cnt=arr[i].sum>cnt?arr[i].sum:cnt;
            }
        }
        printf("%d\n",cnt);
    }
    return 0;
}


//ac代码

/*
题意为:用最少的座位数迎接在不同时间段来的客人 

*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[1000010];
int main()
{
	int t,n,s;
	int i,j;
	int max;
	int hour1,hour2,min1,min2; 
	scanf("%d",&t);
	while(t--)
	{
		memset(a,0,sizeof(a));//一开始要清零 
		scanf("%d",&n);
		max=-100;//纪录最小的座位 
		for(i=0;i<n;++i)
		{
			scanf("%d %d:%d %d:%d",&s,&hour1,&min1,&hour2,&min2);//s表示这个时间段来的人数 
			int sum1=hour1*60+min1;//每个时间都有一个sum1和sum2这个区间 
			int sum2=hour2*60+min2;
			
			for(j=sum1;j<sum2;++j)//当两区间有公共部分时,数组a[i]刚才也存了一个数了 
			{
				a[j]+=s;
				if(a[j]>max)//当数组a纪录的座位数大于max,要把max更新 
					max=a[j];
			}
		}
		printf("%d\n",max);	
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值