POJ 1328 南阳oj 287 Radar【区间选点问题】

17 篇文章 0 订阅
描述
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

 

输入
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros
输出
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
样例输入
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
样例输出
Case 1: 2
Case 2: 1

 

//以某个点为圆心,r为半径画圆与x轴有两个交点,以这两个点为一个区间,再利用会场安排问题的思路做 


#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
struct radar
{
	double x1,x2;
}a[1010];

int cmp(radar a,radar b)//一般按照右坐标排序 
{
	return a.x2<b.x2;
}
int main()
{
	int x,y;
	int n,r,i,num=0,flag;
	while(~scanf("%d%d",&n,&r),n+r)
	{
		int i=0,cnt;
		flag=0;
		
		while(n--)
		{
			scanf("%d%d",&x,&y);
			if(y>r)//如果纵坐标大于半径,就不可能了 
			{				
				flag=1;							
			}		
			else
			{
				double temp=sqrt(1.0*r*r-y*y);
				i++;
				a[i].x1=x*1.0-temp;//记录一个区间 
				a[i].x2=x*1.0+temp;
			}
		}
		if(flag) 
		{
			printf("Case %d: -1\n",++num);
			continue;			
		}
		else
		{
			int t=i;
			sort(a+1,a+t+1,cmp);//我是从1开始的 			 			
			double tem=a[1].x2;
			cnt=1; 
			for(i=2;i<=t;++i)
			{
				if(a[i].x1<=tem)//如果有重合部分,只需要一个就够了,前面已经计算了,这里就直接跳过 
					continue;
				else
				{
					tem=a[i].x2;
					++cnt;
				}
			}
			printf("Case %d: %d\n",++num,cnt);
		}
	}	
	return 0;
}



//以某个点为圆心,r为半径画圆与x轴有两个交点,以这两个点为一个区间,再利用会场安排问题的思路做 


#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
struct radar
{
	double x1,x2;
}a[1010];

int cmp(radar a,radar b)//一般按照右坐标排序 
{
	return a.x2<b.x2;
}
int main()
{
	double x,y,r;
	int n,num=0,flag;
	while(~scanf("%d%lf",&n,&r),n+r)
	{
		int i=0,cnt;
		flag=0;		
		while(n--)
		{
			scanf("%lf%lf",&x,&y);
			if(y>r)//如果纵坐标大于半径,就不可能了 
			{				
				flag=1;							
			}		
			else
			{
				double temp=sqrt(r*r-y*y);
				
				a[i].x1=x-temp;//记录一个区间 
				a[i++].x2=x+temp;
			}
		}
		if(flag) 
		{
			printf("Case %d: -1\n",++num);
			continue;			
		}
		
		int t=i;
		sort(a,a+t,cmp);//我是从1开始的 			 			
		double tem=a[0].x2;
		cnt=1;
		for(i=1;i<t;++i)
		{
			if(a[i].x1>tem)//如果有重合部分,只需要一个就够了,前面已经计算了,这里就直接跳过 
			{
				tem=a[i].x2;
				++cnt;
			}
		}
		printf("Case %d: %d\n",++num,cnt);		
	}	
	return 0;
}



#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
struct radar
{
	double x1,x2;
}a[1010];

int cmp(radar a,radar b)
{
	return a.x2<b.x2;
}
int main()
{
	int x,y;
	int n,r,i,num=0,flag;
	while(~scanf("%d%d",&n,&r),n+r)
	{
		int i=0,cnt=1;
		flag=0;
		
		while(n--)
		{
			scanf("%d%d",&x,&y);
			if(y>r)
			{				
				flag=1;							
			}		
			else
			{
				double temp=sqrt(1.0*r*r-y*y);
				i++;
				a[i].x1=x*1.0-temp;
				a[i].x2=x*1.0+temp;
			}
		}
		if(flag) 
		{
			printf("Case %d: -1\n",++num);
			continue;			
		}
		else
		{
			int t=i;
			sort(a+1,a+t+1,cmp);
			
			double tem=a[1].x2;
			for(i=2;i<=t;++i)
			{
				if(a[i].x1<=tem)
				continue;
				else
				{
					tem=a[i].x2;
					++cnt;
				}
			}
			printf("Case %d: %d\n",++num,cnt);
		}
	}	
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值