C++——序列按要求转换

题目描述:

小明有一个空序列a,但是他不太喜欢这个序列,因此他想通过一些操作改变序列a,接下来小明将依次进行n次操作,其中第i次操作分为以下两步:

1.将数字i加到序列a的头部。

2.反转序列,即(a_{1}a_{2}a_{3}、...、a_{i}变为a_{i}、...、a_{3}a_{2}a_{1})。 小明想知道n次操作之后,序列a会变为什么样子,你能帮助他吗?  

【输入】

一个整数n(1\leqslant n\leqslant 100000),表示小明要进行n次操作。

【输出】

一行,n个整数,表示n次操作后的序列a

【输入样例1】

4

【输出样例1】

3 1 2 4

【输入样例2】

5

【输出样例2】

4 2 1 3 5

代码

#include <iostream>
using namespace std;
int n; 
int main()
{
    cin >> n;
    for (int i=n-1;i>=1;i-=2) 
    {
		cout << i << " ";
    }
    if (n % 2 == 0)
    {
    	for (int i=2;i<=n;i+=2)
    	{
			cout << i << " ";
    	}
	}
	else
	{
		for (int i=1;i<=n;i+=2)
    	{
			cout << i << " ";
    	}
	}
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
桥接模式是一种结构型设计模式,它将抽象和实现分离,使它们可以独立地变化。桥接模式的核心思想是将一个大类或一组类分解成抽象和实现两个独立的维度,使它们可以独立地变化和扩展,同时通过桥接来将它们连接起来。 在C++中,桥接模式通常通过虚函数实现。抽象部分通过基类定义接口,而实现部分通过派生类实现具体的功能。通过将抽象部分的指针作为参数传递给实现部分的函数,就可以实现两个部分的连接。 下面是一个简单的桥接模式的C++示例: ```c++ class Implementor { public: virtual void operation() = 0; virtual ~Implementor() {} }; class ConcreteImplementorA : public Implementor { public: void operation() override { // 具体的实现A } }; class ConcreteImplementorB : public Implementor { public: void operation() override { // 具体的实现B } }; class Abstraction { public: Abstraction(Implementor* implementor) : m_implementor(implementor) {} virtual void operation() = 0; virtual ~Abstraction() {} protected: Implementor* m_implementor; }; class RefinedAbstraction : public Abstraction { public: RefinedAbstraction(Implementor* implementor) : Abstraction(implementor) {} void operation() override { m_implementor->operation(); // 其他操作 } }; int main() { Implementor* implementorA = new ConcreteImplementorA(); Implementor* implementorB = new ConcreteImplementorB(); Abstraction* abstractionA = new RefinedAbstraction(implementorA); Abstraction* abstractionB = new RefinedAbstraction(implementorB); abstractionA->operation(); abstractionB->operation(); delete abstractionA; delete abstractionB; delete implementorA; delete implementorB; return 0; } ``` 在上面的示例中,Implementor是实现部分的抽象基类,ConcreteImplementorA和ConcreteImplementorB是具体的实现类。Abstraction是抽象部分的基类,RefinedAbstraction是抽象部分的具体实现类。在main函数中,我们创建了不同的Implementor和Abstraction对象,并通过它们来完成不同的操作。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值