POJ 1386 欧拉路径判断

自己最近多半是傻逼了。(感觉现在每做一道题就感叹一句)
Play on Words
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 12518 Accepted: 4235
Description

Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us.

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word acm'' can be followed by the wordmotorola”. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door.
Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters ‘a’ through ‘z’ will appear in the word. The same word may appear several times in the list.
Output

Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times.
If there exists such an ordering of plates, your program should print the sentence “Ordering is possible.”. Otherwise, output the sentence “The door cannot be opened.”.
Sample Input

3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok
Sample Output

The door cannot be opened.
Ordering is possible.
The door cannot be opened.

题意:给你一堆字符串,当一个字符串的首字母和另一个字符串的尾字母相同时,它们可以接起来,问所有的字符串能否接成连续的一串。(字符串只包含小写字母)

题解:
将每个字符串的首字母和尾字母连一条有向边,判断这张图是否存在欧拉路径。
真的是一点都不能省啊。(因为总共才26个点,也就判26*26次)用邻接矩阵比邻接表好。邻接表重复的边太多了。
毕竟是一个邻接表超时的傻逼。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int N = 30;
const int M = 1000 + 10;

int n;
int in[N],out[N];
char s[M];

#define ms(x,y) memset(x,y,sizeof(x))
bool check(){
    int u=0,v=0;
    for(int i=0;i<26;i++){
        if(in[i]==out[i]+1&&u==0) u=1;
        else if(in[i]==out[i]-1&&v==0) v=1;
        else if(in[i]!=out[i]) return false;
    }
    return true;
}

bool vis[N];
int mp[N][N];

void dfs(int u){
    for(int v=0;v<26;v++){
        if(mp[u][v]&&!vis[v]){
            vis[v]=true;
            dfs(v);
        }
    }
}

int t;
void update(){
    t=0;
    ms(in,0);ms(out,0);ms(vis,0);ms(mp,0);
}

void print(){
    if(t==0)
        printf("Ordering is possible.\n");
    else printf("The door cannot be opened.\n");    
}

int main(){
    scanf("%d",&n);
    for(register int i=1;i<=n;i++){
        update();
        int m,tt=-1;
        scanf("%d",&m);
        for(register int j=1;j<=m;j++){
            scanf("%s",s);
            int len=strlen(s);
            int u=s[0]-'a',v=s[len-1]-'a';
            if(tt==-1) tt=u;
            in[u]++,out[v]++;
            mp[u][v]=1,mp[v][u]=1;
        }
        dfs(tt);
        for(int i=0;t==0&&i<26;i++){
            for(int j=0;j<26;j++)
               if(mp[i][j]&&!vis[j]){
                   t=1;break;
               }
        }
        if(t==0){
           if(!check()) t=1;
           else t=0;}
        print();
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值