POJ 1364 King 差分约束

King

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 13994 Accepted: 4970

Description

Once, in one kingdom, there was a queen and that queen was expecting a baby. The queen prayed: “If my child was a son and if only he was a sound king.” After nine months her child was born, and indeed, she gave birth to a nice son.
Unfortunately, as it used to happen in royal families, the son was a little retarded. After many years of study he was able just to add integer numbers and to compare whether the result is greater or less than a given integer number. In addition, the numbers had to be written in a sequence and he was able to sum just continuous subsequences of the sequence.

The old king was very unhappy of his son. But he was ready to make everything to enable his son to govern the kingdom after his death. With regards to his son’s skills he decided that every problem the king had to decide about had to be presented in a form of a finite sequence of integer numbers and the decision about it would be done by stating an integer constraint (i.e. an upper or lower limit) for the sum of that sequence. In this way there was at least some hope that his son would be able to make some decisions.

After the old king died, the young king began to reign. But very soon, a lot of people became very unsatisfied with his decisions and decided to dethrone him. They tried to do it by proving that his decisions were wrong.

Therefore some conspirators presented to the young king a set of problems that he had to decide about. The set of problems was in the form of subsequences Si = {aSi, aSi+1, …, aSi+ni} of a sequence S = {a1, a2, …, an}. The king thought a minute and then decided, i.e. he set for the sum aSi + aSi+1 + … + aSi+ni of each subsequence Si an integer constraint ki (i.e. aSi + aSi+1 + … + aSi+ni < ki or aSi + aSi+1 + … + aSi+ni > ki resp.) and declared these constraints as his decisions.

After a while he realized that some of his decisions were wrong. He could not revoke the declared constraints but trying to save himself he decided to fake the sequence that he was given. He ordered to his advisors to find such a sequence S that would satisfy the constraints he set. Help the advisors of the king and write a program that decides whether such a sequence exists or not.

Input

The input consists of blocks of lines. Each block except the last corresponds to one set of problems and king’s decisions about them. In the first line of the block there are integers n, and m where 0 < n <= 100 is length of the sequence S and 0 < m <= 100 is the number of subsequences Si. Next m lines contain particular decisions coded in the form of quadruples si, ni, oi, ki, where oi represents operator > (coded as gt) or operator < (coded as lt) respectively. The symbols si, ni and ki have the meaning described above. The last block consists of just one line containing 0.

Output

The output contains the lines corresponding to the blocks in the input. A line contains text successful conspiracy when such a sequence does not exist. Otherwise it contains text lamentable kingdom. There is no line in the output corresponding to the last “null” block of the input.

Sample Input

4 2
1 2 gt 0
2 2 lt 2
1 2
1 0 gt 0
1 0 lt 0
0

Sample Output

lamentable kingdom
successful conspiracy

Source

Central Europe 1997

题意:
求一个长度为n的序列Si,使其满足给出的m条限制,每条限制表示为数字a,b,字符gt/lt,数字x,gt代表某个子序列S[a],S[a+1],…,S[a+b]的和大于x,lt代表这个子序列的和小于x。问这样的S序列是否存在。

题解:
经典的差分约束。判断解的存在。
如果图中存在负环,则不存在解。其余情况【包括不连通,代表无数多组解】都存在解。
可以添加超级源点s,或者枚举每一个联通块。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;

const int N = 1000 + 10;
const int M = 100000 + 10;

inline int read(){
    int x=0,f=1;char ch=getchar();
    while(ch<'0'||ch>'9') {if(ch=='-') f=-1;ch=getchar();}
    while(ch>='0'&&ch<='9') {x=x*10+ch-'0';ch=getchar();}
    return x*f;
}

int n,m;
struct node{
    int pre,v,w;
}e[M<<1];

int num=0,head[N];
void addedge(int from,int to,int w){
    e[++num].pre=head[from],e[num].v=to;
    e[num].w=w;head[from]=num;
}

deque<int> q;
int ti[N],dis[N];
bool vis[N];

bool spfa(int s){
    q.push_front(s);dis[s]=0;
    while(!q.empty()){
        int u=q.front();q.pop_front();
        vis[u]=false;
        for(int i=head[u];i;i=e[i].pre){
            int v=e[i].v;
            if(dis[v]>dis[u]+e[i].w){
                dis[v]=dis[u]+e[i].w;
                if(!vis[v]){
                    if(!q.empty()&&dis[v]<dis[q.front()]) q.push_front(v);
                    else q.push_back(v);
                    vis[v]=true;ti[v]++;
                    if(ti[v]>n+2) return false;
                }
            }
        }
    }
    return true;
}

#define ms(x,y) memset(x,y,sizeof(x))
void update(){
    ms(head,0);num=0;
    memset(dis,0x7,sizeof(dis));
    memset(ti,0,sizeof(ti));
}

int main(){
    while(1){
        n=read();
        if(n==0) break;
        m=read();update();
        for(register int i=1;i<=m;++i){
            char ss[3];
            int u=read(),v=read();
            scanf("%s",ss);int w=read();
            if(ss[0]=='g') addedge(u+v+1,u,-w-1);
            else addedge(u,u+v+1,w-1);
        }
        bool flag=true;
        for(int i=1;i<=n+1;++i){
            if(dis[i]==dis[0]){
               if(!spfa(i)) {flag=false;break;}
            }
        }
        if(flag) puts("lamentable kingdom");
        else puts("successful conspiracy");
        /*for(register int i=1;i<=n+1;++i) addedge(0,i,0);
        if(spfa(0)) puts("lamentable kingdom");
        else puts("successful conspiracy");     */
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值