HDU 2830 Matrix Swapping II

HDU 2830 Matrix Swapping II

Time Limit: 9000/3000 MS (Java/Others)
Memory Limit: 32768/32768 K (Java/Others)

Problem Description


Given an N * M matrix with each entry equal to 0 or 1. We can find some rectangles in the matrix whose entries are all 1, and we define the maximum area of such rectangle as this matrix’s goodness.

We can swap any two columns any times, and we are to make the goodness of the matrix as large as possible.

Input


There are several test cases in the input. The first line of each test case contains two integers N and M (1 ≤ N,M ≤ 1000). Then N lines follow, each contains M numbers (0 or 1), indicating the N * M matrix

Output


Output one line for each test case, indicating the maximum possible goodness.

Sample Input


3 4
1011
1001
0001
3 4
1010
1001
0001

Sample Output


4
2

Note


Huge Input, scanf() is recommended.

Source


2009 Multi-University Training Contest 2 - Host by TJU

Recommend


gaojie

Submit

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

#define MAXN 1005

bool cmp(int a, int b)
{
    return a > b;
}

int main()//这是一道DP题
{
    int N, M;
    int i, j;
    int visit[MAXN], num[MAXN];//visit代表到某点列上连续的1的数量
    char str[MAXN];
    int ans;
    while(~scanf("%d %d", &N, &M))
    {
        ans = 0;
        memset(visit, 0, sizeof(visit));
        memset(num, 0, sizeof(num));
        for(i = 0; i < N; i++)
        {
            scanf("%s", str);
            for(j = 0; j < M; j++)
            {
                int t = str[j] - '0';
                if(t)//如果是1的话,在第i行第j列就多了一个连续的1
                    visit[j]++;
                else//否则在第i行第j列没有连续的1
                    visit[j] = 0;
                num[j] = visit[j];//用num数组单独存储这一行的visit
            }
            sort(num, num+M, cmp);//因为列是可交换的,所有可以把num从大到小排序,可以在x-y坐标系中想象num数组
            for(j = 0; j < M; j++)
                ans = max(ans, num[j]*(j+1));//矩形面积S=y*x,y是num[j],x是(j+1),找到最大的矩形面积,每输入1行就计算1次ans
        }
        printf("%d\n", ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值