PAT 1017. Queueing at Bank (25) 屡次段错误,终于过了

1017. Queueing at Bank (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10000) - the total number of customers, and K (<=100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:
7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10
Sample Output:
8.2

思路就是窗口人满了,时间就跳到用时最短的窗口。窗口没满,时间就跳到下一个顾客到来的时间。
一定要注意最后边界数据的处理

#include<iostream>
#include<stdio.h>
#include<iomanip>
#include<string>
#include<algorithm>

using namespace std;
string now="07:59:59";
int q[101]={0};                     //队列长度
    int n,k;
    int p=0;                        //轮到第几个顾客
    long long themin=1;
     long long nnow=-1;            //现在时间,8点为0
     int flag[101]={0};           //窗口有没有人的标志


long long change(string a)         //将字符串时间转成数字
 {
     int x=(a[0]-'0')*10+a[1]-'0'-8;
     int y=(a[3]-'0')*10+a[4]-'0';
     int z=(a[6]-'0')*10+a[7]-'0';
     return x*3600+y*60+z;
 }


struct ZZ
 {
     string arrive;
     int need;
     bool operator < (const ZZ &A) const
      {
        return arrive<A.arrive;
      }
 }tutu[10011];

 int judgeflag()      //判断几个窗口有人
  {
      int bb=0;
      for(int i=0;i<k;i++)
        if(flag[i]==1) bb++;

      return bb;
  }

int main()
{
    long long wtime=0;        //总等待时间
    cin>>n>>k;
     for(int i=0;i<n;i++)
      cin>>tutu[i].arrive>>tutu[i].need;
     sort(tutu,tutu+n);
    tutu[n].arrive="17:00:01";   //重要!一定要加上。不然所有顾客进队后,p指向下一个未初始化的,造成下面判断错误

     while(nnow<=100000)
     {
         nnow+=themin;
         for(int i=0;i<k;i++)
            q[i]-=themin;
            themin=99999;
        for(int i=0;i<k;i++)
        {
            if(q[i]<=0) flag[i]=0;
            if(q[i]<=0&&nnow>=change(tutu[p].arrive)&&tutu[p].arrive<="17:00:00")     //窗口为空且可以入队,就入队
            {  flag[i]=1;
              q[i]=tutu[p].need*60;
             
              wtime+=nnow-change(tutu[p].arrive);
              p++;
            }
           if(q[i]>0&&q[i]<themin) themin=q[i];      //窗口有人,就跳到最小窗口结束的时间。
        }
          if(judgeflag()<k&&tutu[p].arrive<="17:00:00")    //窗口没满,跳到下一个顾客来的时间。之前没加判断下一个顾客到来时间,可能会造成themin为负值
             
             themin=change(tutu[p].arrive)-nnow;

          if(judgeflag()==0&&tutu[p].arrive>"17:00:00") break;  //窗口为空且下个顾客不行,结束。
     }
      float last=(float)wtime;
      last/=60;
      last/=p;
      cout<<fixed<<setprecision(1)<<last;


    return 0;
}

  最后总结经验教训就是,以下一个对象的状态作为走向的判断条件时,一定要注意最后那个对象之后还要加入一个虚拟对象作为边界条件

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值