编译源码出现的问题couldn't find import for class

项目中需要修改源码,加入对以太网的支持。找到了一个开源的android项目,将其中的ethernet部分移到eclair的源码下。出现以下问题。

 

frameworks/base/ethernet/java/android/net/ethernet/IEthernetManager.aidl:3: couldn't find import for class android.net.ethernet.EthernetDevInfo
make: *** [out/target/common/obj/JAVA_LIBRARIES/framework_intermediates/src/ethernet/java/android/net/ethernet/IEthernetManager.java] 错误 1

 

 

 

[
EthernetDevInfo.aidl文件
code]package android.net.ethernet;

parcelable EthernetDevInfo;
[/code]EthernetDevInfo是继承Parcelable 的。

编译N次都出现这个错误,网上也有人遇到类似情况,不过是在eclipse下,我这是源码中遇到的,不知道如何是好。

 

 

解决方法:

 

步骤一:

 

我现在没有在Android.mk中编译IEthernetManager,而是将IEthernetManager.aidl生成IEthernetManager.java后放到out/target/common/obj/JAVA_LIBRARIES/framework_intermediates/src的相应目录下。

 

步骤二:

 

修改framework/base/Android.mk

 

在LOCAL_AIDL_INCLUDES := $(FRAMEWORKS_BASE_JAVA_SRC_DIRS)
前加上
LOCAL_AIDL_INCLUDES := frameworks/base/ethernet/java

阅读更多
个人分类: android
上一篇JNI调用Native方法,抛出UnsatisfiedLinkError异常
下一篇一个APK中是否可以读写另外一个APK的SharedPreferences数据
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭
关闭