2017 ACM-ICPC 亚洲区(西安赛区)网络赛 Trig Function

2017 ACM-ICPC 亚洲区(西安赛区)网络赛 Trig Function

f(cos(x))=cos(n∗x) holds for all xxx.

Given two integers nnn and mmm, you need to calculate the coefficient of xmx^mx​m​​ in f(x)f(x)f(x), modulo 998244353998244353998244353.
Input Format

Multiple test cases (no more than 100100100).

Each test case contains one line consisting of two integers nnn and mmm.

1≤n≤109,0≤m≤1041 \le n \le 10^9,0 \le m \le 10 ^ 41≤n≤10​9​​,0≤m≤10​4​​.
Output Format

Output the answer in a single line for each test case.
样例输入

2 0
2 1
2 2

样例输出

998244352
0
2

切比雪夫多项式

这里写图片描述

注意:!!是双阶乘

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
typedef long long ll;
#define mod 998244353
ll q[100010];
ll n,m;
void init(){
    q[0]=1;
    for (int i=1;i<100010;i++){
        q[i]=q[i-1]*i%mod;
    }
}
ll qpow(ll n,ll m){
    ll res=1;
    while(m){
        if (m&1)
            res=res*n%mod;
            n=n*n%mod;
            m>>=1;
    }
    return res;
}
int main(){
    init();
    while(~scanf("%lld%lld",&n,&m)){
        if (n<m){
            printf("0\n");
            continue;
        }
        if (n%2&&m%2==0){
            printf("0\n");
            continue;
        }
        if (n%2==0&&m%2){
            printf("0\n");
            continue;
        }
        ll fz=n%mod;
        if (m>=1){
            for (int i=n-m+1;i<=n+m-1;i++){
                if (i%2==(n+m-2)%2)
                fz=fz*i%mod;
            }
            ll x=fz*qpow(q[m],mod-2)%mod;
            if ((n-m)/2%2)
                x=-x;
            printf("%lld\n",(x+mod)%mod);
        }
        else {
            ll t =1;
            for (int i=m+n-1;i<=n-m;i++){
                if (i%2==(n+m-2)%2)
                t=t*i%mod;
            }
            ll x =fz*qpow(q[m],mod-2)%mod*qpow(t,mod-2)%mod;
            if ((n-m)/2%2)
                x=-x;
                printf("%lld\n",(x+mod)%mod);
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值