Video Surveillance POJ - 1474

A friend of yours has taken the job of security officer at the Star-Buy Company, a famous depart- ment store. One of his tasks is to install a video surveillance system to guarantee the security of the customers (and the security of the merchandise of course) on all of the store’s countless floors. As the company has only a limited budget, there will be only one camera on every floor. But these cameras may turn around to look in every direction.

The first problem is to choose where to install the camera for every floor. The only requirement is that every part of the room must be visible from there. In the following figure the left floor can be completely surveyed from the position indicated by a dot, while for the right floor, there is no such position, the given position failing to see the lower left part of the floor.

Before trying to install the cameras, your friend first wants to know whether there is indeed a suitable position for them. He therefore asks you to write a program that, given a ground plan, de- termines whether there is a position from which the whole floor is visible. All floor ground plans form rectangular polygons, whose edges do not intersect each other and touch each other only at the corners.
Input
The input contains several floor descriptions. Every description starts with the number n of vertices that bound the floor (4 <= n <= 100). The next n lines contain two integers each, the x and y coordinates for the n vertices, given in clockwise order. All vertices will be distinct and at corners of the polygon. Thus the edges alternate between horizontal and vertical.

A zero value for n indicates the end of the input.
Output
For every test case first output a line with the number of the floor, as shown in the sample output. Then print a line stating “Surveillance is possible.” if there exists a position from which the entire floor can be observed, or print “Surveillance is impossible.” if there is no such position.

Print a blank line after each test case.
Sample Input
4
0 0
0 1
1 1
1 0
8
0 0
0 2
1 2
1 1
2 1
2 2
3 2
3 0
0
Sample Output
Floor #1
Surveillance is possible.

Floor #2
Surveillance is impossible.

半平面交

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <cmath>
using namespace std;
#define eps 1e-8
const int MAXN=10010;
int n;
double r;
int cCnt,curCnt;
struct point{
    double x,y;
};
point points[MAXN],p[MAXN],q[MAXN];
void getline(point x,point y, double &a, double &b, double &c){
    a=y.y-x.y;
    b=x.x-y.x;
    c=y.x*x.y-x.x*y.y;
}
void initial(){
    for (int i=1;i<=n;i++)
        p[i]=points[i];
    p[n+1]=p[1];
    p[0]=p[n];
    cCnt=n;
}
point intersect(point x,point y,double a,double b,double c){
    double u=fabs(a*x.x+b*x.y+c);
    double v=fabs(a*y.x+b*y.y+c);
    point pt;
    pt.x=(x.x*v+y.x*u)/(u+v);
    pt.y=(x.y*v+y.y*u)/(u+v);
    return pt;
}
void cut(double a,double b,double c){
    curCnt=0;
    int i;
    for (i=1;i<=cCnt;i++){
        if (a*p[i].x+b*p[i].y+c>=0)
            q[++curCnt]=p[i];
        else{
            if (a*p[i-1].x+b*p[i-1].y+c>0){
                q[++curCnt]=intersect(p[i],p[i-1],a,b,c);
            }
            if (a*p[i+1].x+b*p[i+1].y+c>0){
                q[++curCnt]=intersect(p[i],p[i+1],a,b,c);
            }
        }
    }
    for (i=1;i<=curCnt;i++)
        p[i]=q[i];
    p[curCnt+1]=q[1];
    p[0]=p[curCnt];
    cCnt=curCnt;
}

void solve(){
    initial();
    for (int i=1;i<=n;i++){
        double a,b,c;
        getline(points[i],points[i+1],a,b,c);
        cut(a,b,c);
    }
}
void zhuanhua(){
    for (int i=1;i<(n+1)/2;i++){
        swap(points[i],points[n-i]);
    }
}
int main(){
    int tt=1;
        while(~scanf("%d",&n)&&n) {
            for (int i = 1; i <= n; i++) {
                scanf("%lf%lf", &points[i].x, &points[i].y);
            }
            //zhuanhua();
            points[n + 1] = points[1];

            solve();
            printf("Floor #%d\n",tt++);
            if (cCnt < 1) {
                printf("Surveillance is impossible.\n");
            } else {
                printf("Surveillance is possible.\n");
            }
            printf("\n");
        }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值