another a+b处理多组数据的输入

1 篇文章 0 订阅

Description

      Just for add problem test, but notice it, this time you got multiple inputs(may contain more than 3 data cases,notice it!)

       Input
  1 2
      2 3
      3 4
       Output
  3
      5
      7
       Sample Input
       1 2
       Sample Output
        3

这个题很简单,只是加法运算,可是卡在了实现多组数据输入上......

【转】如何处理多组数据的输入?

在C和C++里,我们可以使用 scanf 的返回值,如果返回值为EOF,则说明已无下一组数据,也可以使用cin的返回值,如果cin返回0,则说明无更多数据。

在java中,可以使用Scanner的 hasNext() 函数判断是否还有数据,hasNext() 返回 true,说明还有后续数据,若返回false,说明无更多数据。

Here is a sample solution for problem 1002 using C++:

#include <iostream>

using namespace std;

int main()

{

    int a,b;

    while(cin >> a >> b)

          cout << a+b << endl;

}

Here is a sample solution for problem 1002 using C:

#include <stdio.h>

int main()

{

      int a,b;

      while(scanf("%d %d",&a, &b) != EOF)

             printf("%d\n",a+b);

             return 0;

}

Here is a sample solution for problem 1002 using PASCAL:

program p1002(Input,Output);

var

    a,b:Integer;

begin

    while not eof(Input) do

       begin

           Readln(a,b);

           Writeln(a+b);

       end;

end.

Here is a sample solution for problem 1002 using Java:

import java.util.Scanner;

public class Main {

          public static void main(String[] args) {

          Scanner in = new Scanner(System.in);

           while (in.hasNextInt()) {

                      int a = in.nextInt();

                      int b = in.nextInt();

                      System.out.println(a + b);

           }

     }

}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值