搜索 BFS HDU - 1072 

Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.
Output
For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.
Sample Input
3
3 3
2 1 1
1 1 0
1 1 3
4 8
2 1 1 0 1 1 1 0
1 0 4 1 1 0 4 1
1 0 0 0 0 0 0 1
1 1 1 4 1 1 1 3
5 8
1 2 1 1 1 1 1 4 
1 0 0 0 1 0 0 1 
1 4 1 0 1 1 0 1 
1 0 0 0 0 3 0 1 
1 1 4 1 1 1 1 1 
Sample Output
4
-1
13
/*题意:一个迷宫,起始炸弹引爆时间给定为6。2表示起点,3表示终点。1表示可以走,0表示不能走。
        4表示炸弹引爆时间重新置为6。一个人背着炸弹从起点出发。问他是否在炸弹爆炸前走出迷宫。
        如果可以,输出他所需要的最短时间,如果不行,输出-1。
           规则:     1、如果刚好走到3,炸弹引爆时间变为0,则算走不出迷宫。
                      2、如果刚好走到4,准备reset引爆时间。但是走到该点时引爆时间刚好变为0,则不能重新设置。
                      3、每一个4都可以走多次,只要他需要。*/

/* 注意BFS时 遇到重置装置 时间重置之后 这个位置也不能再走一次 把这个位置置为0即可*/

#include<iostream>
#include<stdio.h>
#include <queue>
using namespace std;
int sx,sy,n,m;
int maps[100][100];
struct node
{
    int x;
    int y;
    int time;
    int stemp;
};
queue <node> q;
int dir[4][2]={-1,0,0,-1,1,0,0,1};
int pd(int x,int y)
{
    if(x<0 || x>=n || y<0 || y>=m) return 0;
    else return 1;
}
void BFS(int sx,int sy)
{
    int min_stemp=0;
    while(!q.empty()) q.pop();
    node temp;
    temp.x=sx;
    temp.y=sy;
    temp.time=1;
    temp.stemp=0;
    q.push(temp);
    while(!q.empty())
    {
        temp=q.front(); q.pop();
        if(temp.time==6) continue;
        for(int i=0;i<4;i++)
        {
            node next;
            next.x=temp.x+dir[i][0];
            next.y=temp.y+dir[i][1];
            if(pd(next.x,next.y) && maps[next.x][next.y] )
            {
                next.time=temp.time+1;
                next.stemp=temp.stemp+1;
                if(maps[next.x][next.y]==4)
                {
                    maps[next.x][next.y]=0;
                    next.time=1;
                }
                if(maps[next.x][next.y]==3)
                {
                    min_stemp=next.stemp;
                    break;
                }
                q.push(next);
            }
        }
        if(min_stemp!=0) break;
    }
    if(min_stemp==0) printf("-1\n");
    else printf("%d\n",min_stemp);
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
        {
            scanf("%d",&maps[i][j]);
            if(maps[i][j]==2) {sx=i;sy=j;}
        }
         BFS(sx,sy);
    }

    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值