【C/C++】Maximum Subsequence Sum/最大子列和问题

11 篇文章 2 订阅

7-1 Maximum Subsequence Sum(25 分)

Given a sequence of K integers { N1N2, ..., NK }. A continuous subsequence is defined to be { NiNi+1, ..., Nj } where 1ijK. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4


题目源于:https://pintia.cn/problem-sets/16/problems/663

题目要求:输入一个数列,求其最大子列和。

思路分析:动态规划问题。具体参考17至33行代码以及注释


// MaximumSubsequenceSum.cpp: 定义控制台应用程序的入口点。
//

#include "stdafx.h"
#include<iostream>
#include <vector>
using namespace std;

int main()
{
	int N;				//输入数列长度
	cin >> N;
	int * array = new int[N];
	for (int i = 0; i < N; i++) {
		cin >> array[i];
	}
	//sum为子列和,MAX为最大子列和,first记录子列和的第一项,src为最大子列和的第一项,end为最大子列和的最后一项
	int sum=0,first=0,src=N-1,end=N-1,max=-1;
	//动态规划
	for (int i = 0; i < N; i++) {
		sum += array[i];
		//当前子列和>最大子列和时修改MAX,即SUM>MAX时,将max = sum.
		if (sum > max) {
			max = sum;
			src = first;
			end = i;
		}
		//sum<0时重置sum,first
		if (sum <0) {
			first = i + 1;
			sum = 0;
		}
	}
	if (max<0) cout << 0 << ' ' << array[0] << ' ' << array[N - 1];
	else cout << max << ' ' << array[src] << ' ' << array[end];
	delete[] array;
    return 0; 
}



  • 2
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值