A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.
Input
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
Output
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5
Sample Output
2
3
题意:
给出N个数字,每个数字不大于10000,给出一个S,在N个数字中挑选出连续的a的数字,使这a个数字的和大于或等于S。请问这个a最小是多少。
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int num[100010];
int main()
{
int t,n,s;
scanf("%d",&t);
while(t--)
{
memset(num,0,sizeof(num));
scanf("%d%d",&n,&s);
for(int i=0;i<n;i++)
scanf("%d",&num[i]);
int l=0,r=0,sum=0,res=n+1;
while(true)
{
while(r<n&&sum<s) //右指针向右移动
{
sum+=num[r];
r++;
}
if(sum<s)break;
res=min(r-l,res); //更新最小的序列中元素数
sum-=num[l]; //左指针向右移动
l++;
}
if(res<n+1)printf("%d\n",res);
else printf("0\n");
}
return 0;
}