字典树题目

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents. 

In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo". 

An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list that begins with "car". 

Input

The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

Output

The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.

Sample Input

carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate

Sample Output

carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car

carbonate carbona

大致题意:给出一系列单词,要求输出能代表这些单词的最短字符串,要求字符串不能为其他单词的前缀。

解题思路:把这些单词建立一个字典树,查找每个单词的v值,及这个前缀出现的次数,若出现的次数大于一,就把这个 单词输出,直到出现的次数为一时停止输出。

#include<stdio.h>  
#include<string.h>  
#include<algorithm>  
#include<queue>  
using namespace std;  
typedef struct node  
{  
    int cnt;  //标记每个字母出现的次数
    node *next[26];  
}Trie;  
Trie root;  
void ct(char *str)  //建立字典树
{  
    int len,i,j;  
    len=strlen(str);  
    Trie *p=&root,*q;  
    for(i=0;i<len;i++)  
    {  
        int id=str[i]-'a';  
        if(p->next[id]==NULL) //若下一个节点为空,建立新的节点 
        {  
            q=new Trie;  
            q->cnt=1;  //初始时为1
            for(j=0;j<26;j++)  
             q->next[j]=NULL; //下个指针全部赋初始值 
            p->next[id]=q;  
            p=p->next[id]; //向下走 
        }  
        else  
        {  
            p->next[id]->cnt++;  //如果有相同的,标记加一
            p=p->next[id]; //向下走 
        }  
    }  
}  
void Find_Trie(char*str)  //查找
{  
    int len,i,j,id;  
    len=strlen(str);  
    Trie*p=&root;  
    for( i=0; i<len; i++){  
         id=str[i]-'a';  
         if( p->next[id]==NULL)  
             return ;  
        if(p->next[id]->cnt==1) //若走到标记为一,则全部输出 
        {  
            printf("%c",str[i]);  
            return ;  
        }  
        else if(p->next[id]->cnt>1)  //若不为一,一个一个输出
        {  
            printf("%c",str[i]);  
         p=p->next[id];  //向下走   
        }  
    }  
    return ;  
}     
char xx[1050][25];  
int main()  
{  
    char map[1050];  
    int ii=0;  
    while(scanf("%s",map)!=EOF)  
    {  
        ct(map);  
        strcpy(xx[ii],map);  
        ii++;  
    }  
    for(int j=0;j<ii;j++)  
    {  
        printf("%s ",xx[j]);  
        Find_Trie(xx[j]);  
        printf("\n");  
    }  
    return 0;  
}   



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值