hdojEXCEL排序

Problem Description
Excel可以对一组纪录按任意指定列排序。现请你编写程序实现类似功能。
 

Input
测试输入包含若干测试用例。每个测试用例的第1行包含两个整数 N (<=100000) 和 C,其中 N 是纪录的条数,C 是指定排序的列号。以下有 N
行,每行包含一条学生纪录。每条学生纪录由学号(6位数字,同组测试中没有重复的学号)、姓名(不超过8位且不包含空格的字符串)、成绩(闭区间[0, 100]内的整数)组成,每个项目间用1个空格隔开。当读到 N=0 时,全部输入结束,相应的结果不要输出。
 

Output
对每个测试用例,首先输出1行“Case i:”,其中 i 是测试用例的编号(从1开始)。随后在 N 行中输出按要求排序后的结果,即:当 C=1 时,按学号递增排序;当 C=2时,按姓名的非递减字典序排序;当 C=3
时,按成绩的非递减排序。当若干学生具有相同姓名或者相同成绩时,则按他们的学号递增排序。
 

Sample Input
  
  
3 1 000007 James 85 000010 Amy 90 000001 Zoe 60 4 2 000007 James 85 000010 Amy 90 000001 Zoe 60 000002 James 98 4 3 000007 James 85 000010 Amy 90 000001 Zoe 60 000002 James 90 0 0
 

Sample Output
  
  
Case 1: 000001 Zoe 60 000007 James 85 000010 Amy 90 Case 2: 000010 Amy 90 000002 James 98 000007 James 85 000001 Zoe 60 Case 3: 000001 Zoe 60 000007 James 85 000002 James 90

000010 Amy 90

此题用三个sort函数解决。

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct student{
    char  id[110];
    char  name[110];
    int  score;
}arr[100100];
bool cmp1(student a,student b)
{
    return strcmp(a.id,b.id)<0;
}
bool cmp2(student a,student b)
{
    if(strcmp(a.name,b.name)==0)
        return strcmp(a.id,b.id)<0;
    else
        return strcmp(a.name,b.name)<0;

}
bool cmp3(student a,student b){
    if(a.score==b.score)
    return strcmp(a.id,b.id)<0;
    else
    return a.score<b.score;
}
int main()
{
    int n,c;
    int i,t;
    t=0;
    while(scanf("%d%d",&n,&c)!=EOF)
    {
        if(n==0&&c==0)
        break;
        for(i=0;i<n;i++)
        scanf("%s%s%d",arr[i].id,arr[i].name,&arr[i].score);
        if(c==1)
        sort(arr,arr+n,cmp1);
    
        
        else if(c==2)
        
            sort(arr,arr+n,cmp2);
        
        else if(c==3)
            sort(arr,arr+n,cmp3);
            t++;
            printf("Case %d:\n",t);
            for(i=0;i<n;i++){
                printf("%s %s %d\n",arr[i].id,arr[i].name,arr[i].score);
        }
        
   } 
   return 0;
  }
  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值