light oj 1078 - Integer Divisibility

Description

If an integer is not divisible by 2 or 5, some multiple of that number in decimal notation is a sequence of only a digit. Now you are given the number and the only allowable digit, you should report the number of digits of such multiple.

For example you have to find a multiple of 3 which contains only 1's. Then the result is 3 because is 111 (3-digit) divisible by 3. Similarly if you are finding some multiple of 7 which contains only 3's then, the result is 6, because 333333 is divisible by 7.

Input

Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case will contain two integers n (0 < n ≤ 106 and n will not be divisible by 2 or 5) and the allowable digit (1 ≤ digit ≤ 9).

Output

For each case, print the case number and the number of digits of such multiple. If several solutions are there; report the minimum one.

Sample Input

3

3 1

7 3

9901 1

Sample Output

Case 1: 3    111能被3整除.

Case 2: 6     333333能被7整除

Case 3: 12   111111111111能被9901整除

此题用同余定理

(a*b)%c=(a%c*b%c)%c;
(a+b)%c=(a%c+b%c)%c;
代码如下:

#include<stdio.h>
#include<algorithm>
#include<stdlib.h>
#include<math.h>
using namespace std;
int main()
{
	int t,k=0;
	scanf("%d",&t);
	while(t--)
	{
	__int64 n,m,flag;
	scanf("%I64d%I64d",&n,&m);
	flag=m%n;
	int ans=1;
	while(flag)
	{
		flag=(flag*10+m)%n;//其实这跟我们平常手算除法的思想差不多一样
		ans++;
	}

	k++;
	printf("Case %d: ",k);	
	printf("%d\n",ans);
	}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值