UVA 10200 Prime Tim

Euler is a well-known matematician, and, among many other things, he discovered that the formulan2 + n + 41 produces a prime for 0 ≤ n < 40. For n = 40, the formula produces 1681, which is 41 ∗ 41.Even though this formula doesn’t always produce a prime, it still produces a lot of primes. It’s knownthat for n ≤ 10000000, there are 47,5% of primes produced by the formula!So, you’ll write a program that will output how many primes does the formula output for a certaininterval.

Input

Each line of input will be given two positive integer a and b such that 0 ≤ a ≤ b ≤ 10000. You mustread until the end of the file.OutputFor each pair a, b read, you must output the percentage of prime numbers produced by the formula inthis interval (a ≤ n ≤ b) rounded to two decimal digits.

Sample Input

0 39

0 40

39 40

Sample Output

100.00

97.56

50.00

给出一个范围a->b,然后求满足关系的素数率.需要素数打表

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int sum[10010];
bool prime(int x)
{
	int i;
	for(i=2;i*i<=x;i++)
	{
		if(x%i==0)
		return false;
	}
	return true;
}
void getprime()
{
	sum[0]=1;
	for(int i=1;i<10010;i++)
	{
		if(prime(i*i+i+41))
		sum[i]=sum[i-1]+1;
		else
		sum[i]=sum[i-1];
	}
}
int main()
{
	getprime();
	int a,b;
	while(scanf("%d%d",&a,&b)!=EOF)
	{
		int ans=sum[b]-sum[a]+prime(a*a+a+41);//求满足条件的个数.
		double k=1.0*ans/(b-a+1);
		k=(int)(k*10000+0.5)/100.0;//四舍五入,100后面需要加.0(刚开始一直错就是因为这个);
		printf("%.2lf\n",k);
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值