(ACM)Let the Balloon Rise

Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters. A test case with N = 0 terminates the input and this test case is not to be processed.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink

Author

WU, Jiazhi

我的代码

#include <stdio.h>
#include <string.h>
int main() 
{
	char str[1000][15],ar[15];
	int i,j,n,q;
	int m=1,k=1;
	while(scanf("%d",&n)==1)
	{
		if(n>0&&n<=1000)
		{
			for(i=0;i<n;i++)
			{
				scanf("%s",str[i]);
			}
			for(i=0;i<n-1;i++)
			{
				for(j=i+1;j<n;j++)
				{
					if(strcmp(str[i],str[j])==0)
					{
						m++;
						if(m>k)
						{
							n=k;
							strcpy(ar,str[i]);
						}
					}

				}
			}
			
			printf("%s\n",ar);
		}
		else
		{
			return 0;
		}
	}
	return 0;
}

模仿他人的代码

#include <stdio.h>
#include <string.h>
int main()
{
    int n,i,j,num[1000];
    int max=0,t=0;
    char color[1000][16];
    while(scanf("%d",&n)!=EOF)
    {
        if(n)
        {
            num[0]=0;
            scanf("%s",color[0]);
            for(i=1;i<n;i++)
            {
                num[i]=0;
                scanf("%s",color[i]);
                for(j=0;j<i-1;j++)
                {
                	if(strcmp(color[i],color[j])==0)
					{
						num[i]+=1;
					} 
				}
            }
            max=0;
            t=0;
            for(i=1;i<n;i++)
			{
				 if(max<num[i]) 
               	{
                   max=num[i];
                   t=i;
				}
			}
            printf("%s\n",color[t]);
        }
    }
    return 0;
}

题意

题目要求我们输入气球的个数 并在每一行输入气球的颜色,最后输出颜色最多的气球的颜色。

心得

本题考查了字符串数组和字符串函数的用法。在自己写的代码和其他人的比较,自己在定义字符串数组的时候,内存少给了,并且他人的代码又定义了一个整型数组,用来统计每种气球的个数,最后在通过比较数组每个数据的大小,找出元素最大的那个数的小标,最后输出气球最多的那个颜色。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值