[ACM]Elevator

286 篇文章 140 订阅
150 篇文章 0 订阅

Problem Description

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input

There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

Output

Sample Input

1 2
3 2 3 1
0

Sample Output

17
41

Author

ZHENG, Jianqiang

Source

ZJCPC2004

解题思路:

开一个数组用来保存输入的楼层数,变量time为总共的时间,初始化为0,从数组的第个数开始,依次比较当前数与前一个数的大小,分情况time+=(6或4)*(大数-小数),最后time再加上数组中的一个数(楼层数)所用的时间,再加上所有楼层停留的时间。


代码:

#include <iostream>
using namespace std;
int fl[102];
int main()
{
    int n;
    while(cin>>n&&n)
    {
        int i;
        for(i=0;i<n;i++)
            cin>>fl[i];
        int time=0;
        for(i=1;i<n;i++)
        {
            if(fl[i]>fl[i-1])//比较
                time=time+6*(fl[i]-fl[i-1]);
            if(fl[i]<fl[i-1])
                time=time+4*(fl[i-1]-fl[i]);
        }
        cout<<time+6*fl[0]+5*n<<endl;
    }
    return 0;
}

运行截图:



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值