指针:自定义函数length,调用它计算字符串的长度

Description
自定义一个函数int length(char *s),函数返回字符串s的长度。在main函数中输入字符串(长度小于80),调用该函数并输出其长度
Input
多组测试数据,每组输入一个任意字符串(长度小于80)
Output
输出字符串长度
Sample Input
hello
I like music.
oh, my god!
Sample Output
5
13
11

#include<stdio.h>
int length(char*s)
{
    int i,count;
    while(*s!='\0')
    {
        s++;
        count++;
    }
    return count;
 } 
  
 int main()
 {
     char s[80];
     while(gets(s)!=NULL)
     {
         int t;
         t=length(s);
         printf("%d\n",t);
     }
     return 0;
 }

#include<stdio.h>
#include<string.h>
int length(char*s)
{
    int count;
    count=strlen(s);
    return count;
}
int main()
{
    int t;
    char s[80];
    while(gets(s)!=NULL)
    {
        t=length(s);
        printf("%d\n",t);   
    }
    return 0;
}

#include<stdio.h>
int length(char*s)
{
    int count;
    while(*s!='\0')
    {
        *(s++);
        count++;
    }
    return count;
}
int main()
{
    int t;
    char s[80];
    while(gets(s)!=NULL)
    {
        t=length(s);
        printf("%d\n",t);   
    }
    return 0;
}
  • 7
    点赞
  • 25
    收藏
    觉得还不错? 一键收藏
  • 4
    评论
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值