关于在计算中乘法溢出Calculate S(n)


A - Calculate S(n)
Time Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u

Description

Calculate S(n).

S(n)=1 3+2 3 +3 3 +......+n 3 .
 

Input

Each line will contain one integer N(1 < n < 1000000000). Process to end of file.
 

Output

For each case, output the last four dights of S(N) in one line.
 

Sample Input

       
       
1 2
 

Sample Output

       
       
0001 0009
 
AC代码
#include <stdio.h>

int main()
{
    __int64 n,sum;
    while (scanf("%I64d",&n)!=EOF)
    {
        sum=0;
        n=n%10000;
        sum=(n*(n+1)/2)*(n*(n+1)/2)%10000;//  为了防止计算sum中乘法溢出将n=n%10000;因为要求得后4位数。
        printf("%04I64d\n",sum);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值