杭电2122Ice_cream’s world III(kruskal算法与prim算法)

Ice_cream’s world III

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1493 Accepted Submission(s): 510


Problem Description
ice_cream’s world becomes stronger and stronger; every road is built as undirected. The queen enjoys traveling around her world; the queen’s requirement is like II problem, beautifies the roads, by which there are some ways from every city to the capital. The project’s cost should be as less as better.

Input
Every case have two integers N and M (N<=1000, M<=10000) meaning N cities and M roads, the cities numbered 0…N-1, following N lines, each line contain three integers S, T and C, meaning S connected with T have a road will cost C.

Output
If Wiskey can’t satisfy the queen’s requirement, you must be output “impossible”, otherwise, print the minimum cost in this project. After every case print one blank.

Sample Input
  
  
2 1 0 1 10 4 0


Sample Output
  
  
10 impossible

Author
Wiskey

Source

Recommend
威士忌 | We have carefully selected several similar problems for you: 2120 2121 2119 2129 2118

Statistic | Submit | Discuss | Note
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct Rode{
	int f,t,v;
};
Rode rode[10010];
bool cmp(Rode x,Rode y)
{
	return x.v<y.v;
}
int pre[1010];
int find(int x)
{
	while(x!=pre[x])
	x=pre[x];
	return x;
}
void merge(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	pre[fx]=fy;
}
int main()
{
	int n,m,i,j,sum;
	while(~scanf("%d%d",&n,&m))
	{
		for(i=0;i<n;i++)
		pre[i]=i;
		sum=0;
		for(i=0;i<m;i++)
		scanf("%d%d%d",&rode[i].f,&rode[i].t,&rode[i].v);
		sort(rode,rode+m,cmp);
		for(i=0;i<m;i++)
		{
			int fx=find(rode[i].f);
			int fy=find(rode[i].t);
			if(fx!=fy) 
			{
				sum+=rode[i].v;
				merge(rode[i].f,rode[i].t);
			}
		}
		int t=0;
		for(i=0;i<n;i++)
		if(pre[i]==i) t++;
		if(t==1)  
		printf("%d\n\n",sum);
		else printf("impossible\n\n");
  }
	return 0;
}<pre name="code" class="html">#include<stdio.h>
#include<string.h>
#define INF 0x3f3f3f
int n,m,map[1010][1010];
void prim()
{
	int visit[1010],lowcost[1010],next,i,j,min,sum;
	sum=0;
	memset(visit,0,sizeof(visit));
	for(i=0;i<n;i++)
	lowcost[i]=map[0][i];
	visit[0]=1;
	for(i=1;i<n;i++)
	{
		min=INF;
		for(j=0;j<n;j++)
		{
			if(!visit[j]&&min>lowcost[j])
			{
				min=lowcost[j];
				next=j;
			}
		}
			if(min==INF)
			{
				printf("impossible\n\n");
				return ;
			}
			sum+=min;
			visit[next]=1;
			for(j=0;j<n;j++)
			if(lowcost[j]>map[next][j]&&!visit[j])
			lowcost[j]=map[next][j];
		}
		printf("%d\n\n",sum);
}
int main()
{
	int i,j,s,t,c;
	while(~scanf("%d%d",&n,&m))
	{
	  for(i=0;i<n;i++)
	  for(j=0;j<n;j++)
	  {
	  	if(i==j)  map[i][j]=0;
	  	else map[i][j]=INF;
	  }
	  while(m--)
	  {
	  	scanf("%d%d%d",&s,&t,&c);
	  	if(map[s][t]>c)  
	  	map[s][t]=map[t][s]=c;
	  }
	  prim();
	}
	return 0;
}	

 
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值