【搜索-DFS】hdu1010 Tempter of the Bone

Tempter of the Bone
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze. 

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him. 
 

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following: 

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or 
'.': an empty block. 

The input is terminated with three 0's. This test case is not to be processed. 
 

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise. 
 

Sample Input

     
     
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output

     
     
NO YES

开始考虑要不要用BFS,后来觉得BFS无法走完所有情况,果断DFS了。值得注意的是这次学会了使用奇偶剪枝,很大的降低了程序运行时间。运用后仍然WA,原来是起始的点忘记标记了……

奇偶剪枝:http://baike.baidu.com/view/7789287.htm?fr=aladdin

代码如下:

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
#include<cmath>
#include<queue>
using namespace std;
int flag[10][10],sum,x1,z1,x2,z2,dir[4][2]={0,-1,-1,0,0,1,1,0},T,f;
char Map[10][10];
void dfs(int x,int y,int t)
{
    if(Map[x][y]=='D'&&t==T)
        {
            f=1;
            cout<<"YES\n";
            return ;
        }
    if(f==1||t>T)
       {
        return ;
       }
    for(int i=0;i<4;i++)
    {
        int xx=x+dir[i][0];
        int yy=y+dir[i][1];
        if(Map[xx][yy]=='X'||flag[xx][yy]==1)
            continue;
        flag[xx][yy]=1;
        dfs(xx,yy,t+1);
        if(f==1)
            return ;
        flag[xx][yy]=0;
    }
    if(t==0&&f==0)
    cout<<"NO\n";
}
int main()
{
    int n,m,i,j,x1,z1;
    while(~scanf("%d%d%d",&n,&m,&T))
    {
        f=0;
        if(n==0&&m==0&&T==0)
            break;
        memset(flag,0,sizeof(flag));
        memset(Map,'X',sizeof(Map));
        for(int i=1;i<=n;i++)
        {
            getchar();
            for(int j=1;j<=m;j++)
            {
                cin>>Map[i][j];
                if(Map[i][j]=='S')
                {
                    x1=i;z1=j;
                }
                if(Map[i][j]=='D')
                {
                    x2=i;z2=j;
                }
            }
        }
        int h=abs(x1-x2)+abs(z1-z2);
        if((T-h)&1)
        {
            cout<<"NO\n";
            continue;
        }
        flag[x1][z1]=1;
        dfs(x1,z1,0);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值