杭电1063 hdu1063Exponentiation

Exponentiation

Time Limit: 2000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8385    Accepted Submission(s): 2393


Problem Description
Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 

This problem requires that you write a program to compute the exact value of R n where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25. 
 

Input
The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.
 

Output
The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.
 

Sample Input
  
  
95.123 12 0.4321 20 5.1234 15 6.7592 9 98.999 10 1.0100 12
 

Sample Output
  
  
548815620517731830194541.899025343415715973535967221869852721 .00000005148554641076956121994511276767154838481760200726351203835429763013462401 43992025569.928573701266488041146654993318703707511666295476720493953024 29448126.764121021618164430206909037173276672 90429072743629540498.107596019456651774561044010001 1.126825030131969720661201
 

Source
 


求输入数据的N次方,高精度,调试了一个小时,原以为写那么乱AC不过呢,结果还是过了,附代码+注释:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[630],b[630],c[660],i,j,k,l,m,n,cnt;
char s[10];
void pplus(int a[])
{
	int i,j,k,l;
	memset(c,0,sizeof(c));
	for(i=0;i<10;i++)//大数乘模板 
	for(j=0;j<200;j++)
	c[i+j]+=b[j]*a[i];
	
	for(i=0;i<200;i++)
	{
		if(c[i]>=10)
		c[i+1]+=c[i]/10;
		c[i]%=10;
	}
	for(i=0;i<300;i++)
	b[i]=c[i];
}
int main()
{
	while(scanf("%s%d",s,&n)!=EOF)
	{
		l=strlen(s);
		cnt=0; 
		for(i=l-1;i>=0;i--)//判断小数点后有几位数 
		if(s[i]=='.')
		cnt=l-1-i;
		int help=0;
		memset(c,0,sizeof(c));
		memset(b,0,sizeof(b));
		int nmd=0;
		
		for(i=l-1;i>=0;i--)//先暂时消除输入数据的后置0 
		if(s[i]!='0')
		break;
		
		if(s[i]=='.')//如果输入的类似1.   这样的数据 
		nmd=1;
		for(i=l-1;i>=0;i--)//判断输入有无 小数点 
		if(s[i]=='.')
		break;
		if(i==-1)
		nmd=1;
		
		b[0]=1;
		
		
		for(i=l-1;i>=0;i--) //储存数据 
		if(s[i]>='0'&&s[i]<='9')
		a[help++]=s[i]-'0';
		
		
		for(i=0;i<n;i++) //递归相乘 
		pplus(a);
		
		
		for(i=200;i>=cnt*n;i--)//输出 
		if(b[i])
		break;
		for(i;i>=cnt*n;i--)
		printf("%d",b[i]);
		if(nmd==0) //如果结果是小数 
		printf(".");
		int cnm=0;
		for(;i>=0;i--)
		{
			cnm=0;
			for(j=i;j>=0;j--)//消除后置0,其实可以直接输入成浮点型判断的 
			{
				if(b[j])//但是我比较懒 
				{
					cnm=1;
					break;
				}
			}
			if(cnm)
			printf("%d",b[i]);
		}
		printf("\n");
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值