杭电5523 Game

Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1202    Accepted Submission(s): 414


Problem Description
XY is playing a game:there are N pillar in a row,which numbered from 1 to n.Each pillar has a jewel.Now XY is standing on the S-th pillar and the exit is in the T-th pillar.XY can leave from the exit only after they get all the jewels.Each time XY can move to adjacent pillar,or he can jump to boundary ( the first pillar or the N-th pillar) by using his superpower.However,he needs to follow a rule:if he left the pillar,he no can not get here anymore.In order to save his power,XY wants to use the minimum number of superpower to pass the game.
 

Input
There are multiple test cases, no more than 1000 cases.
For each case,the line contains three integers:N,S and T. (1N10000,1S,TN)
 

Output
The output of each case will be a single integer on a line: the minimum number of using superpower or output -1 if he can't leave.
 

Sample Input
  
  
4 1 4 4 1 3
 

Sample Output
  
  
0 1
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5589  5588  5587  5584  5583 
 


思维题,如果够缜密,肯定能1A,为什么没有1 A呢,因为翻译不给你,注意,在n>1的情况下起点==终点就不可能完成了输出-1:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n,start,eend;
int ffabs(int a,int b)//求差值绝对值 
{
	if(a-b>0)
	return a-b;
	return b-a;
}
int main()
{
	while(scanf("%d%d%d",&n,&start,&eend)!=EOF)
	{
		if(n==1)//就一个点输出0 
		{
			printf("0\n");
			continue;
		}
		else if(ffabs(start,eend)==(n-1))//起点跟终点恰好在两端 
		{
			printf("0\n");
			continue; 
		}
		else if(start==eend)//如果起点==终点则不可能 
		printf("-1\n");
		else if(ffabs(start,eend)==1||start==1||start==n)//如果起点在两端 
		{//或者起点在终点旁边则只需要用超能力跳一下 
			printf("1\n");//比如5 2 3 只需要按如下走2 1 5 4 3,跳了一下 
			continue;
		}
		else//否则就是跳两下 
		printf("2\n");
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值