I was trying to solve problem '1234 - Harmonic Number', I wrote the following code

Time Limit:3000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

I was trying to solve problem '1234 - Harmonic Number', I wrote the following code

long long H( int n ) {
   
 long long res = 0;
   
 for( int i = 1; i <= n; i++ )
        res
 = res + n / i;
   
 return res;
}

Yes, my error was that I was using the integer divisions only. However, you are given n, you have to find H(n) as in my code.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n < 231).

Output

For each case, print the case number and H(n) calculated by the code.

Sample Input

11

1

2

3

4

5

6

7

8

9

10

2147483647

Sample Output

Case 1: 1

Case 2: 3

Case 3: 5

Case 4: 8

Case 5: 10

Case 6: 14

Case 7: 16

Case 8: 20

Case 9: 23

Case 10: 27

Case 11


处理超时的问题。附注释:
#include<math.h>
#include<stdio.h>
#include<string.h>
int n,i,j,k,l,flag=1,t;
int main()//主程序部分写成函数 ,超时了n次 
{
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
	long long k=sqrt(n);//求到2^16次方是不会超市的 
	long long m=0;
	for(i=1;i<k+1;i++)
	{
	m+=n/i;//前边的按正常计算 ,可计算到前1/k。 
	if(n/i>n/(i+1))//算了k个数后,开始找规律。 
	m+=(n/i-n/(i+1))*i;//从n到n/2这些值都为1,从n/2到n/3之间的数都为2...; 
	if(k*k+i-1==n)//倒着加回去,相当于处理了后1/2然后2/3,3/4,4/5...计算了后边(k-1/k) 
	m=m-k;//先输出发现有一些部分多加了,发现从n==k*k开始到n==k*k+k-1,这些数多了k; 
	}
		printf("Case %d: %lld\n",flag++,m);
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值