NYOJ234吃土豆(双层动态规划)

吃土豆

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 4
描述
Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.


Now, how much qualities can you eat and then get ?
输入
There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M,N<=500.
输出
For each case, you just output the MAX qualities you can eat and then get.
样例输入
4 6
11 0 7 5 13 9
78 4 81 6 22 4
1 40 9 34 16 10
11 22 0 33 39 6
样例输出
242

思路:首先找出每一行能吃的最大土豆数,在按照列dp一次就可以找出最大数了

#include<stdio.h>
#include<string.h> 
#define max(x,y)(x>y?x:y)
int map[510][510];
int dp[510][510][2];
int maxR[510];
int dp2[510][2];
int main()
{
	int m,n,i,j,k;
	while(scanf("%d%d",&m,&n)!=EOF)
	{
		memset(dp,0,sizeof(dp));
		memset(dp2,0,sizeof(dp2));
		for(i=1;i<=m;i++)
			for(j=1;j<=n;j++)
				scanf("%d",&map[i][j]);
		for(k=1;k<=m;k++)
		{
			for(i=1;i<=n;i++)
			{
				dp[k][i][0]=max(dp[k][i-1][0],dp[k][i-1][1]);
				dp[k][i][1]=dp[k][i-1][0]+map[k][i];
			}
		}
		for(i=1;i<=m;i++)
			maxR[i]=max(dp[i][n][0],dp[i][n][1]);
		for(i=1;i<=m;i++)
		{
			dp2[i][0]=max(dp2[i-1][0],dp2[i-1][1]);
			dp2[i][1]=dp2[i-1][0]+maxR[i];
		}
		int res=max(dp2[m][0],dp2[m][1]);
		printf("%d\n",res);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值