Quicksum,入门级算法

Problem Description

A checksum is an algorithm that scans a packet of data and returns a single number. The idea is that if the packet is changed, the checksum will also change, so checksums are often used for detecting transmission errors, validating document contents, and in many other situations where it is necessary to detect undesirable changes in data.

For this problem, you will implement a checksum algorithm called Quicksum. A Quicksum packet allows only uppercase letters and spaces. It always begins and ends with an uppercase letter. Otherwise, spaces and letters can occur in any combination, including consecutive spaces.

A Quicksum is the sum of the products of each character’s position in the packet times the character’s value. A space has a value of zero, while letters have a value equal to their position in the alphabet. So, A=1, B=2, etc., through Z=26. Here are example Quicksum calculations for the packets “ACM” and “MID CENTRAL”:

ACM: 11 + 23 + 313 = 46 MID CENTRAL: 113 + 29 + 34 + 40 + 53 + 65 + 714 + 820 + 918 + 101 + 1112 = 650

Input
The input consists of one or more packets followed by a line containing only # that signals the end of the input. Each packet is on a line by itself, does not begin or end with a space, and contains from 1 to 255 characters.

Output
For each packet, output its Quicksum on a separate line in the output.

**Sample Input**
ACM
MID CENTRAL
REGIONAL PROGRAMMING CONTEST
ACN
A C M
ABC
BBC
#

**Sample Output**
46
650
4690
49
75
14
15

这道题的意思是:
1.要循环输入字符串,直到遇到#结束;
2.当长度超过255时,也结束;
3.当输入都为大写时,按题目规则计算s(开头结尾空格不算,中间空格为零,A=1,B=2……Z=26;字母在字符串中对应位置字母在字母表中对应位置)eg:ACM字符串的s=11+23+313=46;
4.输出s。

来自航电oj上的这道基础题让我头疼了一晚上,提交了无数次终于ac了,在网上找资料发现错误的太多了,所以我在这里留下自己的”精华“
以下为ac代码,不是最简单,只是提供一种方法,供大家参考交流,有问题私信我呀!

```
	#include <stdio.h>
	#include <string.h>
	int main()
	{
    int i,n,s,j,k;
    char a[300];
    while(gets(a))
    {
        s=0;
        k=0;
        n=strlen(a);
        if(n>255)               //题目要求单个字符串长度小于255
            break;
        if(a[0]=='#')           //#结束循环输入
            break;
        for(i=n-1; i>0; i--)    //将末尾的空格去掉
            if(a[i]==' ')
                n--;
            else break;
        for(i=0; i<n; i++)      //去点开头占位的空格
            if(a[i]==' ')
                k++;
            else break;
        for(i=k; i<n; i++)     //正常情况k=0;i=k=0
        {
            if(a[i]>=65 && a[i]<=90)
            {
                a[i]=a[i]-64;
                s=s+a[i]*(i-k+1);
            }
            if(a[i]==' ')      
                ;
        }
        if(s==0)      //s==0存在两种情况,一是全是空格,二是输入不是大写字母
            continue;
        printf("%d\n",s);
    }
    return 0;
}
```
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

oioihoii

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值