POJ 3630

Phone List
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 25546 Accepted: 7745

Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:

  • Emergency 911
  • Alice 97 625 999
  • Bob 91 12 54 26

In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output "YES" if the list is consistent, or "NO" otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES

题目大意:

给出几组电话号码,在某一组号码中,判断是否存在某一号码为其他号码的前缀,存在输出NO,否则输出YES。

这道题第一首想到采用字典树实现对每组号码的存储,再逐一对组中的号码进行判断。

还有一种方法是对每组中的电话号码进行排序,然后再从最短的电话开始与后面的电话号码进行比较,判断当前的电话号码是否是其他某些号码的前缀,直到该组结尾。

比较两种方法,Trie树空间消耗大,时间复杂度低,排序那个则相反。下面两种方法代码均实现。

Trie实现:

/* **********************************************
Auther: zyq_zhang
Created Time: 2015/9/14 18:49:41
File Name   :POJ3630_2.cpp
*********************************************** */
#include <iostream>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <list>
#include <map>
#include <set>
#include <sstream>
#include <string>
#include <vector>
#include <cstdio>
#include <ctime>
#include <bitset>
#include <algorithm>
using namespace std;
struct node
{
    int next[10];
    int cnt;
    void init()
    {
        cnt=0;
        memset(next,-1,sizeof(next));
    }
} T[100100];

int le;

void insert(char* s)
{
    int x=0,p=0,i=0;
    while(s[i])
    {
        x=s[i]-'0';
        if(T[p].next[x]==-1)
        {
            T[le].init();
            T[p].next[x]=le++;
        }
        p=T[p].next[x];
        T[p].cnt++;
        i++;
    }
}

bool ok(char* s)
{
    int i=0,p=0;
    while(s[i])
    {
        int x=s[i]-'0';
        if(T[p].next[x]==-1)
        {
            return false;
        }
        p=T[p].next[x];
        i++;
    }
    return T[p].cnt>1;
}

int main()
{
    int t,n;
    char s[10010][11];
    scanf("%d",&t);
    while(t--)
    {
         le=1;
        T[0].init();//必须每次更新根节点
        bool flag=true;
        scanf("%d",&n);
        for(int i=0; i<n; i++)
        {
            scanf("%s",s[i]);
            insert(s[i]);
        }
        int k=0;
        for( k=0; k<n; k++)
        {
            if(ok(s[k]))
            {
                flag=false;
                break;
            }
        }
        if(flag) printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

排序实现:

#include<cstdio>
#include<string>
#include<iostream>
#include<algorithm>
using namespace std;
string number[10005];
bool search(int n)
{
    int len,i,j;
    for( i=0;i<n-1;i++)
    {
        len=number[i].size();
        for( j=0;j<len;j++)
        {
            if(number[i][j]!=number[i+1][j])
                break;
        }
        if(j==len) return true;
    }
    return false;
}
int main()
{
      int t,n;
      scanf("%d",&t);
      while(t--)
      {
          scanf("%d",&n);
          for(int i=0;i<n;i++)
          {
              cin>>number[i];
          }
          sort(number,number+n);
          if(search(n))
            printf("NO\n");
          else
            printf("YES\n");
      }
     return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值