[POJ 3254]Corn Fields(状压DP)

Description


Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can’t be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input


Line 1: Two space-separated integers: M and N
Lines 2..M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output


Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input


2 3
1 1 1
0 1 0

Sample Output


9

Hint


Number the squares as follows:

1 2 3
4

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

Solution


一块矩形要种玉米,有些地方不可以种,而可种的地方也不能有两块玉米挨在一起,求方案数

状压DP
用i&(i<<1)来判断一行有没有相邻的1
用state[j]&state[k]来判断有没有上下相邻的1
(state[j]&a[1])==state[j]表示state[j]在a[i]上可放

#include<cstring>
#include<cstdlib>
#include<iostream>
#include<cstdio>
#include<string>
#define Mod 100000000
using namespace std;
int m,n;
int f[13][4100],cnt;
int a[13],state[4100];
void init()
{
    memset(f,0,sizeof(f));
    memset(a,0,sizeof(a));
    cnt=0;
    for(int i=0;i<=(1<<n);i++)
    {
        if(!(i&(i<<1)))state[++cnt]=i;
    }
}
int main()
{
    while(~scanf("%d%d",&m,&n))
    {
        init();
        for(int i=1;i<=m;i++)
        {
            int x;
            for(int j=1;j<=n;j++)
            {
                scanf("%d",&x);
                a[i]<<=1;
                a[i]+=x;
            }
        }
        for(int j=1;j<=cnt;j++)
        {
            if((state[j]&a[1])==state[j])f[1][j]=1;
        }
        for(int i=2;i<=m;i++)
        {
            for(int j=1;j<=cnt;j++)
            {
                if((state[j]&a[i])!=state[j])continue;
                for(int k=1;k<=cnt;k++)
                {
                    if(state[j]&state[k])continue;
                    f[i][j]+=f[i-1][k];
                    f[i][j]%=Mod;
                }
            }
        }
        int ans=0;
        for(int i=1;i<=cnt;i++)
        {
            ans+=f[m][i];
            ans%=Mod;
        }
        printf("%d\n",ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值