Description
One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).
You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.
You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.
Input
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
Output
Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.
Sample Input
10 6 AACATGAAGG TTTTGGCCAA TTTGGCCAAA GATCAGATTT CCCGGGGGGA ATCGATGCAT
Sample Output
CCCGGGGGGA AACATGAAGG GATCAGATTT ATCGATGCAT TTTTGGCCAA TTTGGCCAAA
CODE:
#include <iostream>
using namespace std;
typedef struct
{
char* val;
int key;
} node;
int getnum(char* s)
{
int sum=0;
char *s2,*s3;
for(s2=s;*s2!='\0';++s2)
for(s3=s2+1;*s3!='\0';++s3)
if(*s2-*s3>0)
++sum;
return sum;
}
int main(int argc, char* argv[])
{
int m,n,i;
cin>>m>>n;
node *in=new node[n];
node temp;
for(i=0;i<n;++i)
{
in[i].val=new char[m+1];
cin>>in[i].val;
in[i].key=getnum(in[i].val);
}
bool moved=true;
i=0;
while(moved)
{
moved=false;
for(i=0;i<n-1;++i)
if(in[i].key>in[i+1].key)
{
moved=true;
temp=in[i];
in[i]=in[i+1];
in[i+1]=temp;
}
}
for(i=0;i<n;++i)
{
cout<<in[i].val<<endl;
delete in[i].val;
}
delete in;
return 0;
}