1007 DNA Sorting

22 篇文章 0 订阅

Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted). 

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length. 

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

CODE:

#include <iostream>
using namespace std;
typedef struct  
{
	char* val;
	int key;
} node;
int getnum(char* s)
{
	int sum=0;
	char *s2,*s3;
	for(s2=s;*s2!='\0';++s2)
		for(s3=s2+1;*s3!='\0';++s3)
			if(*s2-*s3>0)
				++sum;
	return sum;
}
int main(int argc, char* argv[])  
{  
	int m,n,i;
	cin>>m>>n;
	node *in=new node[n];
	node temp;
	for(i=0;i<n;++i)
	{
		in[i].val=new char[m+1];
		cin>>in[i].val;
		in[i].key=getnum(in[i].val);
	}
	bool moved=true;
	i=0;
	while(moved)
	{
		moved=false;
		for(i=0;i<n-1;++i)
			if(in[i].key>in[i+1].key)
			{
				moved=true;
				temp=in[i];
				in[i]=in[i+1];
				in[i+1]=temp;
			}
	}
	for(i=0;i<n;++i)
	{
		cout<<in[i].val<<endl;
		delete in[i].val;
	}
	delete in;
	return 0;
}  




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值