1088 滑雪

22 篇文章 0 订阅

Description

Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子 
 1  2  3  4 5

16 17 18 19 6

15 24 25 20 7

14 23 22 21 8

13 12 11 10 9

一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。

Input

输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。

Output

输出最长区域的长度。

Sample Input

5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

Sample Output

25

CODE:

#include <stdio.h>
#include <string.h>

int h[100][100],t[100][100];
int col,row;

int getTime(int r,int c)
{
	if(t[r][c]>=0)
		return t[r][c];

	int max=1,time;
	//up
	if(r>0&&h[r-1][c]<h[r][c])
	{
		time=getTime(r-1,c)+1;
		max=max>=time?max:time;
	}
	//down
	if(r<row-1&&h[r+1][c]<h[r][c])
	{
		time=getTime(r+1,c)+1;
		max=max>=time?max:time;
	}
	//left
	if(c>0&&h[r][c-1]<h[r][c])
	{
		time=getTime(r,c-1)+1;
		max=max>=time?max:time;
	}
	//right
	if(c<col-1&&h[r][c+1]<h[r][c])
	{
		time=getTime(r,c+1)+1;
		max=max>=time?max:time;
	}
	t[r][c]=max;
	return max;
}

int main()
{
	//freopen("test.txt", "r", stdin);
	memset(h,0,sizeof(h));
	memset(t,-1,sizeof(t));
	int i,j,max=0,temp;
	scanf("%d%d",&row,&col);
	for(i=0;i<row;++i)
		for(j=0;j<col;++j)
			scanf("%d",&h[i][j]);
	for(i=0;i<row;++i)
		for(j=0;j<col;++j)
		{
			temp=getTime(i,j);
			max=max>=temp?max:temp;
		}
	printf("%d\n",max);
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值