题目 (后有题目大意)
the phone catalogue listed these numbers:
Emergency 911
Alice 97 625 999
Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
输入
The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
输出
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
样例输入
2
3
911
97625999
91125426
5
113
12340
123440
12345
98346
样例输出
NO
YES
题目大意:给定n个长度不超过1010的数字串,判断是否有两个字符串A和B,满足A是B的前缀,若有,输出NO,若没有,输出YES。
本题是 Trie 字典树的模板题。
首先,定义一棵树tr,然后用结点数判断。
具体解析看代码注释:
Code:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int tr[100011][11]; //数组存储 Trie 树
bool b[100011];
char c[12];
int n, tot;
bool judge(char c[])//插入字符串,判断答案
{
int len = strlen (c);
int u = 1;
bool flag = false;
for (int i = 0; i <len; i++)
{
int t = c[i] - '0';
if (!tr[u][t])
{
tr[u][t] = ++tot;
}
else if (i == len - 1)
{
flag = true;//没有插入任何新结点
}
u = tr[u][t];
if (b[u])
{
flag = true;//经过某个有标记的结点
}
}
b[u] = true;
return flag;
}
int main()
{
int t;
scanf ("%d", &t);
while (t--)
{
memset (tr, 0, sizeof (tr));
memset (b, false, sizeof (b)); //初始化
scanf ("%d", &n);
tot = 1; //新建一个根节点
bool j = false;
for (int i = 1; i <= n; i++)
{
scanf ("%s", c);
if (judge (c))
{
j = true;
}
}
if (j)
{
printf ("YES\n");
}
else
{
printf ("NO\n");
}
}
return 0;
}